Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Unable to run any examples or compile new project.



  • Hi,

    I have some older projects from the old system (win7 Qt-5.12.3, Visual Studio 2017) that I wish to port to my new platform (win10 Qt-5.14 VS2019).
    I downloaded and installed Qt 5.14 and installed Qt extension for VS2019, but now I'm unable to run even a simple Qt project. I tried from QtCreator and VisualStudio. They both behave like Qt is not installed and can't find include files.

    Furthermore after creating a new Qt project, they both complain about Variable QMAKE_CXX.COMPILER_MACROS is not defined and msvc-version.conf loaded but QMAKE_MSC_VER isn't set.
    I tried searching about it but the only reference is a 2 year old closed bug report.

    I tried uninstalling Qt and VS and start fresh but the problem persist. This happens both on VS2019 and VS2017. I tried Setting up Kits in QtCreator->Tools->Options->Kits, but nothing works.

    This used to work out of the box and I never had any issues setting up, but now I can't even compile a simple UI program from QtCreator? Did something change in the installation?

    I've been bashing my head against this entire day and can't make any progress.
    Any help is appreciated.

    Thanks.



  • It seems that during setup and opening of QtCreator projects, Windows shell commands are issued. And while investigating I found out that I can't open CMD.exe anymore from the Run menu in Win10.

    Further digging on the issue reveled an anomaly in the Command Processor AutoRun key in the Windows Registry.
    Removing the value enabled for CMD to be run again and QtCreator then opened and built a project without issues.

    Visual Studio still complains about Intellisence, but I believe that it's caused by the same issue and reinstalling the apps should fix the problem.

    EDIT:
    After removing and reinstalling Visual Studio, I can confirm that Qt Apps compile successfully on Visual Studio.


  • Lifetime Qt Champion

    Hi @Simula,

    very good investigation. I've never heard such problems before, but now we know they might exist.

    One more question: Did you upgrade your Win7 to Win10 or did you do a clean re-install of Windows 10?

    Regards



  • I did a clean install of Win10. Installed Qt and made an example project and it was all OK. But that was a few months ago.

    And regarding the issue I had. It didn't have anything to do with Qt. After some more digging today I found out that my OS was infected with a Miner malware called SoundMixer that prevented opening and executing CMD commands.
    I also found an old topic on this forums here, that mentions it here:

    https://forum.qt.io/topic/88567/qt-windows-7-installation-issues/23

    It prevents the execution of any CMD command. I almost always use powershell and didn't notice it by now.

    Regards

    EDIT:
    After reinstalling VS, Qt Extension 2.4.2 revision 0.9 - newer one has issues - the Qt made project made in VS2017 and VS2019 compiled without issues.


Log in to reply