Unable to run application Necessitas SDK : missing Ministro -SOLVED



  • Hello all,

    i download the Necessitas sdk installer for windows, but when I try to run a simple Qt GUI main window on the ARM (Android API 3.2) I get:
    @This application requires Ministro service.
    Would you like to install it@
    I click 'ok' to install it but it says:
    @Can't find Ministro service,
    the application can't start@

    also I get this 'No Activity found ' exception in the Qt creator:
    @W/System.err( 604): android.content.ActivityNotFoundException: No Activity found to handle Intent { act=android.intent.action.VIEW dat=market://search?q=pname:org.kde.necessitas.ministro }
    ....
    ....
    E/WindowManager( 604): Activity org.kde.necessitas.origo.QtActivity has leaked window com.android.internal.policy.impl.PhoneWindow$DecorView@40869030 that was originally added here
    E/WindowManager( 604): android.view.WindowLeaked: Activity org.kde.necessitas.origo.QtActivity has leaked window com.android.internal.policy.impl.PhoneWindow$DecorView@40869030 that was originally added here@

    does this has to do with the Android API version? any ideas?
    Thanks,
    G


  • Moderators

    using a higher API version might solve your problem. Have a try with API 10 or higher.



  • it's Android 3.2 Level 13, so it's not that,
    so it's not that, but thanks.

    I think the key here is the
    'No Activity found to handle Intent' exception, it needs the activity to get the ministro from the market service



  • You'll need to download ministro from Android Market service OR

    You can deploy to include library files (*.so) to target device.
    This settings can be changed in project settings.



  • [quote author="zither" date="1320501503"]You'll need to download ministro from Android Market service OR

    You can deploy to include library files (*.so) to target device.
    This settings can be changed in project settings.[/quote]

    ok, so here is what I did, kind of late so will test it tomorrow:

    1. downloaded the Ministro II + configuration tool apk(es)
    2. used the adb in the package tools to install these apk (adb install XXX.apk while the emulator is on).

    Update:
    did the trick!

    thanks,
    G



  • hello
    I have the same problem and I find this soloution
    just run AVD (build your application)

    in avd Andriod go to the menu >chose browser or search
    write ministro.apk
    click download from sourcefrog
    and install ministro like you install application in andriod phone :D

    Sorry i have bad english :D



  • Hello there,
    I have the same problem. I did like mezvangi did. I installed ministro.apk in android emulator. I simply run the emulator, searched ministro.apk still in android emulator and installed like we do in a usual cell phone.



  • I have installed the ministro II.apk and configuration apk, but the emulator told me the version is not right,maybe I need to install the previous version?
    This night I‘ll try.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.