Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

qt problem while trying to run application



  • i stumbled on a youtube video revolving around a cool project. i downloaded the executable project and tried to run it but i ran into some issues:
    first i had to add some CUDA framework 7.0 dll's to the application folder because they were missing (how this works is described in the youtube comments),
    second the command prompt would throw an error "This application failed to start because it could not find or load the Qt Platform Plugin "Windows" in "" ". another guy in the youtube comments made a thread about this on stackoverflow, the only reply on that thread seems to know how to solve it but i don't know what it means or how it works. i installed qt creator to see if i could make any sense of it but i have zero experience with qt. when i run the application exe now though i get a windows popup saying: this app can't run on your pc and the command prompt would say access is denied. i really hope someone here could help me and the people on youtube figure out how to make this software run. it seems so promising. as i said i have zero experience with qt, i am a beginner developer with c# experience and know a thing or 2 about computers.
    thanks in advance
    bart

    ps my spec: windows 10 64x



  • Hi,
    you can try this:

    • find the version of the qt5core.dll
    • get the full qt download for exactly this version from
      download.qt.io/archive/qt/
    • install qt
    • from the installation directory copy the folder "plugins" into your app directory
    • start the application and have fun


  • thanks for your suggestion, i tried it but it didn't work. i don't really know where i go wrong, it's basically a big shot in the dark for me at this point.

    thanks for your effort!


  • Lifetime Qt Champion

    @specula

    Hi
    The program expects a structure within its run folder along with its runtime DLLs.
    Explained here in detail
    http://www.tripleboot.org/?p=138
    http://www.tripleboot.org/?p=536

    97a57ffa-c188-400f-80e8-ae6d61ac6fb9-image.png image url)

    So from the error you get, it seems it might miss the platform subfolder.

    Where did you download the project and which CUDA dlls did it need ?



  • @mrjj thank you for your reply, i will look into this when i get home! for now, these are the cuda dlls needed and how to add them:

    Download CUDA framework 7.0 from here (940 MB).
    Right click on exe and open with winRAR.
    Go to CUDAToolkit\bin\ and copy those 3 missing libraries curand64_70.dll, cudart64_70.dll, cublas64_70.dll to the app directory.

    this is the project:
    lthis is the project and this is the youtube link describing the project

    bart



  • just did it and it works this way:

    download
    qt-opensource-windows-x86-msvc2013_64-5.6.3.exe
    from download.qt.io/archive/qt/ and install it

    from Qt5.6.3\5.6.3\msvc2013_64\plugins\
    copy the folders "platforms" and "imageformats" into your app-directory
    copy Qt5.6.3\5.6.3\msvc2013_64\bin\Qt5Svg.dll into your app directory

    thats it, it runs.
    however, seems to be a really buggy app, dont know if it really works...



  • thanks it's running! the app seems to work okish but i can't reconstruct any actual buildings because i get a different error saying "load texture failed : material/bldg2/roof.tif. the app has a variety of missing files and problems it seems, which is a shame considering the potential.
    thank you very much for going through this!



  • @specula said in qt problem while trying to run application:

    thanks it's running!

    please don't forget to mark your post as solved!


Log in to reply