QDeclarativeView3D black screen while loading 3D model



  • Hi all,

    I'm writing a QtQuickApplication, in which there should be a box showing a 3D model made in 3ds.
    I took a QML project online that does this job, using a .qml file with this simple piece of code:

    @import QtQuick 1.0
    import Qt3D 1.0
    import Qt3D.Shapes 1.0

    Viewport {
    Mesh {
    id: cube
    source: "cube.3ds"
    }

    Item3D {
        mesh: cube
    }
    

    }@

    I run this qml project, and everything works fine.

    I decide then to import this "sample.qml" file inside my Desktop application, as explained in http://doc.qt.nokia.com/4.7/qml-inte...objects-in-qml. To do so, I promote a QGraphicsView to a QDeclarativeView3D, and in the main cpp file I write:

    @
    ui->graphicsView->setSource(QUrl::fromLocalFile("sample.qml"));
    ui->graphicsView->show();
    @

    where ui->graphicsView is obviously the QDeclarativeView3D widget.

    Now, there's the problem: I run the application, but the QDeclarativeView3D remains always black, even "mousing" over it.
    I also tried giving graphicsView an inexisting file as source, but in that case the QDeclarativeView3D is white: then, is almost sure that the qml file is loaded. I wonder why it can't be shown.

    Any suggestion will be appreciated!

    Thanks in advance,
    Bobbz



  • Have you tried running with -graphicssystem opengl?



  • Thanks for suggestion. Unfortunately, it doesn't work...


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.