Important: Please read the Qt Code of Conduct -

[Moved] Using Qt Creator with 4.8 RC1

  • I have 4.7.4 version of -QT_ Qt SDK installed on my Win7 64 bit PC. I would like to switch to 4.8 RC1 version but its installer does not include QT Creator. Is it possible to use 4.7.4 QT Creator with it or I need to compile it and other tools?
    Thank you

  • you can use Qt Creator for every version. just go to tools->options->Qt4

  • Thank you. It worked! For one project I had to recreate the makefile to use new qmake 4.8.

  • Moderators

    You should always start with a clean build directory when switching Qt versions. Some of the generated files might have changed which can lead to hard to debug problems.

    You can use shadow builds to keep the files generated during the build separate.

  • I am dealing with the same issue on Mac OS X 10.7.2 (Lion). I need to set the path to qmake in the Projects settings. The problem I have is that QT Creator won't let me type the path, but insists I navigate to it.

    There is a symbolic link to qmake in Developer/Tools but it won't let me choose that (it is grayed out). The actual qmake is in /usr/bin which I can navigate to in the open file dialog using ~, but the qmake link and the qmake-4.8 are both grayed out and cannot be selected?

  • Moderators

    gkroeger: I failed to parse your description, maybe due to limited mac-foo.

    Where do you set a qmake path in the project settings? There should not be any place to do that;-)
    How do you navigate to /usr/bin using ~?

  • Tobias:

    In the Mac version of QT Creator you can reach the settings either through the QT Creator->Preferences menu, or by clicking on the Project icon if a project is open.

    On a mac, in the file open dialog, typing ~ brings up a dialog that allows you to type in the path you want.

    But, as for my problem, I solved it by deleting the Nokia preference files in my home directory and allowing QT Creator to auto detect the location of qmake.


  • Moderators

    gkroeger: No, you can not use Qt Creator->Preferences and the Project mode interchangeably. Those are different beasts, the former setting up Qt Creator and the later changing settings for the project. Both tend to have very different settings you can change, too.

  • Hi gkroeger,

    I think I had the same issue than you. Autodetect was broken in my Qt Creator.

    I couldn't fix it without deleting Nokia preference files in the .config home directory.

    Maybe it's a QtCreator issue on OS-X Lion.



  • Moderators

    bunjee: What is broken for you? Did you "file a bugreport": ?

  • Hi Tobias,

    After installing QtCreator latest version my Qt 4.8 system installation was not detected on OS X Lion.

    I think QtCreator user preferences got corrupted by the update process.

    I did not file a bug report for that.

Log in to reply