Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

rsync error



  • Hi,

    I am tring to cross compile qt5 for beagleboneboard,

    I followed the "this guide" pdf in the below link

    https://forum.qt.io/topic/106766/can-we-change-the-compiler-in-qmake/28

    After giving rsync -avz debian@192.168.7.2:/usr sysroot

    getting the error

    rsync error:some files/attr were not transferred (see previous errors) (code 23) at main.c(1668) [generator=3.1.2]

    how to solve this one,(once in another system I proceed next with this error only,but after building the qt and after installation ,while running a simple application getting the same error in qt creator) so i want to solve this error here only,

    please suggest me,

    Thankyou..



  • @Asha said in rsync error:

    rsync error:some files/attr were not transferred (see previous errors) (code 23)

    As it states, whichever file(s) were not transferred successfully have produced their own message in the output from rsync, hence the "see previous errors" message. You need to look at the output and consider/show the message for each one in order to know why....



  • @JonB said in rsync error:

    /show the message for each one in order to know why....

    how to see those messages?



  • @Asha
    If you ran your rsync -avz debian@192.168.7.2:/usr sysroot in a terminal I can only say I would expect rsync to have output information as it went along into the terminal. That's what it usually does.... The -v you are specifying even makes its output verbose...



  • @JonB Sorry I am not able to see the output of that command,because some of the reason system shutdown, after started again and run that command ,here is the result:

    beagle@debian:~/BBB$ rsync -avz debian@192.168.7.2:/usr sysroot
    debian@192.168.7.2's password:
    receiving incremental file list
    rsync: send_files failed to open "/usr/sbin/beagle-tester": Permission denied (13)

    sent 10,081 bytes received 2,341,897 bytes 104,532.36 bytes/sec
    total size is 2,378,179,145 speedup is 1,011.14
    rsync error: some files/attrs were not transferred (see previous errors) (code 23) at main.c(1677) [generator=3.1.3]



  • @Asha said in rsync error:

    rsync: send_files failed to open "/usr/sbin/beagle-tester": Permission denied (13)

    So you have your error message reason. I do not know why that is "Permission denied" for you, or even if that is the correct directory. That's as far as I can help you.



  • @JonB yes, it is correct directory only,

    Any idea where to see those errors...


  • Lifetime Qt Champion

    @Asha So have you checked the permissions of /usr/sbin/beagle-tester ?



  • @Asha
    As @aha_1980 has just written, look at the permissions on that directory. If you really are meant to be writing into /usr/sbin/... for this extraction you are likely to need sudo, as your personal user typically would not have permission to write there?



  • @JonB hi,

    I have checked the permissions of /usr/sbin.beagle-tester ,

    I changed the permissions after this tried once more ,here is the attachment
    rsync.png

    After this,running the appication on qt but getting the
    rsync:mkstemp "/bin/.bbb.OJRX2P" failed :permission denied.

    I find this file,but I am not getting this file in my device..

    getting the same error,some files/attrs were not transferred(see previous errors)(code 23) at main.c

    not getting which files or libraries, I missed.



  • @Asha said in rsync error:

    rsync:mkstemp "/bin/.bbb.OJRX2P" failed :permission denied.

    So again you need to look at the permissions on /bin/.bbb.OJRX2P or on the directory /bin (very likely).

    I don't know what you expect people to say. If rsync fails, and reports permission errors in its output, you need to look at those and resolve, somehow. It's not magic, it reports OS errors as it encounters them.

    The error you see here comes from rsync:mkstemp. Try Googling for mkstemp permission denied. You will come across various posts about this, e.g. https://stackoverflow.com/questions/11039559/rsync-mkstemp-failed-permission-denied-13. Suggest you have a read through those to see what others are encountering and how to resolve.



  • @JonB

    rsync:mkstemp "/bin/.bbb.OJRX2P" failed :permission denied.

    In this case, I tried give the permissions,but i am not have the .bbb.OJRX2P file ,so I gave the permissions to bin folder only,

    but getting the same issues..



  • @Asha
    Which is why I said you now need to read the sample link I gave, and do the Googling, because others have stuff to say about rsync:mkstemp and what you may need to do about it permissions-wise....


Log in to reply