Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Qt for WebAssembly on Windows 10



  • Hello,

    this is a post I placed originally in a wrong topic, so now I am moving it here...
    I am trying to use Qt for WebAssembly on Windows 10, I tried different configuration about Kits, compilers in QtCreator, but I didn't find a way to setup a running configuration.

    Following is my environment:
    OS: Windows 10 /build 1903
    Qt: 5.13.1 WebAssembly, installed from the online installer (I downloaded the WebAssembly Qt build, and didn't compile it)
    Qt Creator: 4.10.0
    emcc (Emscripten gcc/clang-like replacement): 1.38.31 64bit (version 1.38.30 no more available)

    Versions.png Kits.png compiler.png

    I tried different values for ABI for both C and C++ compilers, but no chance to get it working.
    If I try to build a project, in the compile output I get the following:

    mingw32-make: *** [Makefile:405: apphtml] Error -1073741515
    mingw32-make: *** Waiting for unfinished jobs....
            1 file(s) copied.
    10:40:11: The process "C:\Qt\Tools\mingw730_64\bin\mingw32-make.exe" exited with code 2.
    Error while building/deploying project test (kit: Qt 5.13.1 WebAssembly)
    The kit Qt 5.13.1 WebAssembly has configuration issues which might be the root cause for this problem.
    When executing step "Make"
    

    Would it be possible to have a detailed configuration description (for compilers, kit, environment variable for emscripten, etc..) for having things working on Windows 10 ?

    Many thanks



  • Hi,
    first of all: Are you using a linux subsystem? Because you need to use Linux its not possible on windows.
    The secon thing is that the Qt mkspecs need to be specified in the compilers sub.
    In em and em++ both need to have "wasm-emscripten" as Qt mkspecs.

    The third thing is that actually it is still not possible to to build via Qt Creator. You need to use qmake and make.
    After running them the project is build and you are ready to go with a webserver like the simple python one. From there you just open the .html.

    If you need more help just message me, had some issues too as right now there is still the same warning on my linux system as you have with QtVersions. I'll figure that one out soon didn't deal with it until now.


Log in to reply