Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

How to run app as eglfs ubuntu 18?



  • Hi,

    I have a very simple QML project that renders a video into a full screen window. I'd like to run this app without a window manager. When I run my application with:

    QT_QPA_EGLFS_INTEGRATION=none ./video_qt -platform eglfs

    I get this error:

    Cannot find EGLConfig, returning null config
    EGL Error : Could not create the egl surface: error = 0x3005

    Can anyone help please?

    Thanks



  • @mikedev are you positive you have EGLFS properly installed/configured in your Ubuntu setup?
    And just to confirm: X11 is not running, right?

    This post may also shade some light on your issue.



  • Hi @Pablo-J-Rogina,

    Yes, I've double checked my configure flags and -eglfs and -kms was set. I've stopped gdm and I'm running the application from console.

    Since yesterday I've got different issues now, it looks more positive but I'm not sure what to do next:

    QT_QPA_EGLFS_INTEGRATION=eglfs_kms_egldevice ./cube -platform eglfs
    qt.qpa.egldeviceintegration: EGL device integration plugin keys: ("eglfs_emu", "eglfs_kms_egldevice", "eglfs_kms")
    qt.qpa.egldeviceintegration: EGL device integration plugin keys (sorted): ("eglfs_kms_egldevice", "eglfs_kms", "eglfs_emu")
    qt.qpa.egldeviceintegration: Trying to load device EGL integration "eglfs_kms_egldevice"
    qt.qpa.eglfs.kms: New DRM/KMS on EGLDevice integration created
    qt.qpa.egldeviceintegration: Using EGL device integration "eglfs_kms_egldevice"
    qt.qpa.eglfs.kms: platformInit: Opening DRM device
    qt.qpa.eglfs.kms: Found 1 EGL devices
    Failed to query device name from EGLDevice

    If I run the same with sudo I just get this: Could not open DRM (NV) device

    Thanks again



  • Can anyone help me on this please?! I'm really stuck with this.

    Thanks.



  • @mikedev, did you figure this out? I'm having the same issue.



  • Hello! Try this QT_QPA_EGLFS_INTEGRATION=eglfs_kms


Log in to reply