⚠️ Forum Maintenance: Feb 6th, 8am - 14pm (UTC+2)

Qt Creator 4.9.0 and newer issues with sftp on Windows 10

  • I've installed the latest Qt from the online installer 3.1.1 and it has installed Qt Creator 4.9.2. After installing OpenSSH on Windows 10 version 1709, I'm able to successfully use ssh, but not sftp through Qt Creator 4.9.2, but I can successfully use sftp through a command prompt. The device test hangs on "Checking whether an SFTP connection can be set up..." when connected to a real Raspberry Pi 3B+ running the default E-Bike application on a Boot2Qt OS for Raspberry Pi 3. My coworker doesn't have any trouble getting sftp to work, so he can deploy and debug without issues. My coworker is using Qt Creator 4.8.2. I've tried Qt Creator 4.9.0 and found it has the same issue. However, when I install and try Qt Creator 4.8.2, the sftp issue during the test is gone, and I don't even know if 4.8.2 tests sftp because it doesn't show the "Checking whether an SFTP connection can be set up..." message in that earlier version.

    How can I get Qt Creator 4.9.2 to work with sftp on Windows 10 version 1709?

  • Lifetime Qt Champion

    Hi @dean_wittmann,

    your description looks like QTCREATORBUG-22471.

    You can comment and vote there to give this topic a bit more attention.


  • I've experienced the same issue, have you solved it?

  • Lifetime Qt Champion

    Hi @skvorl,

    please comment on the linked bugreport. Thanks

Log in to reply