Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

QtWebengine WebGL issue



  • Hello! I want to load the https://www.google.com/earth/ from my application. I have QApplication::setAttribute(Qt::AA_UseOpenGLES, true); in the main.cpp and set ...settings()->setAttribute(QWebEngineSettings::WebGLEnabled, true); to the QWebEngineView. The problem I get:

    0_1563445418250_2019-07-18_132327.png

    From Google Chrome:
    0_1563449283173_2019-07-18_142625.png

    From my app:
    0_1563449293582_2019-07-18_142746.png

    I have Nvidia Geforce GTX 680 (4 GB of VRAM) and use Qt 5.9.X. I think it should work on my device. How to enable it? Thanks.



  • I have tried setting these command line parameters to my application: --ignore-gpu-blacklist --enable-gpu-rasterization running from console: https://forum.qt.io/topic/82360/problem-with-qt-webengine-hardware-acceleration/2 but it still the same. How should I set them properly to QtWebEngineProcess process?



  • Is QtWebengine supports hardware acceleration and WebGL/WebGL2?



  • Hello!

    I fixed the WebGL/WebGL2 issue by upgrading to QtWebEngine 5.13.0. I contacted the Google support about Google Earth issue, because it is still not loading using QtWebEngine 5.13.0. The answer was:

    Google Earth is exclusively built-in to the Google Chrome and does not support other browsers. Also, there is a Google Earth Beta version which supports other browsers but it is still in Beta branch, so may contain bugs or other issues.

    So, I decided to use Leaflet maps API instead of Google Earth. Now it works well. The issue is resolved.


Log in to reply