Can't get QtWebEngine to work on Raspberry Pi 3B



  • Hello! I try to run the bare most sample of QtWebEngine on a Raspberry Pi using Yocto thud/warrior and EGLFS platform:

    import QtQuick 2.0
    import QtQuick.Window 2.0
    import QtWebEngine 1.5
    
    Window {
        width: 1024
        height: 750
        visible: true
        WebEngineView {
            anchors.fill: parent
            url: "https://www.qt.io"
        }
    }
    

    But I get this on stdout:

    # QTWEBENGINE_DISABLE_SANDBOX=1 qmlscene -platform eglfs 123.qml
    QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/var/volatile/tmp/runtime-root'
    Unable to query physical screen size, defaulting to 100 dpi.
    To override, set QT_QPA_EGLFS_PHYSICAL_WIDTH and QT_QPA_EGLFS_PHYSICAL_HEIGHT (in millimeters).
    Sandboxing disabled by user.
    Warning: Setting a new default format with a different version or profile after the global shared context is created may cause issues with context sharing.
    Trace/breakpoint trap
    

    And this on dmesg (a line on each attempt):

    [ 2742.973347] Unhandled prefetch abort: breakpoint debug exception (0x002) at 0x7143f14a
    [ 2776.056549] Unhandled prefetch abort: breakpoint debug exception (0x002) at 0x6fc3f14a
    [ 3024.671555] Unhandled prefetch abort: breakpoint debug exception (0x002) at 0x6fc3f14a
    

    I have gpu_mem=512 and I use userland drivers, not vc4. Had the very same issue with vc4graphics, though.