Visual Studio Plugin: Qt Designer doesn’t work



  • I've installed the visual studio plugin and I am able to create new qt projects. When I try to launch Qt Designer I receive the error message "No default Qt version found. Please check your Qt Visual Studio Add-in settings", although I actually defined the default version via Qt Options->Qt versions->Add. I selected the qt root directory and I also selected this version as default Qt/Win version.

    The correct version has also been selected for the project settings via Qt Project Settings -> Properties -> Version .

    I am able to compile and execute qt projects, but for some reason I cannot launch the Qt Designer.

    I hope someone here can help me!



  • btw: I am using Windows 7 32bit, Visual Studio 2008, Qt 4.7.0, and Qt visual studio plugin 1.1.6



  • For some reason, I had a similar problem with Qt 4.6. After some time unsuccessfully trying to find out the cause of the problem, I finally installed Qt 4.7 from http://qt.nokia.com/downloads/windows-cpp-vs2008 . Somehow, it works now :o

    In your case, maybe you are not linking properly VS with Qt 4.7 (as a hint, in my computer the Qt folder that must be selected is "C:\Qt\4.7.0\" ). It might also happen that the Qt libraries you selected are not compatible with VS. If you think the problem is the latter, try to reinstall Qt libraries from the link above.

    Hope it helps ;)



  • thanks! I just installed the software from your link and now it works :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.