Planned maintenance has been done but it did not solve the problem. So work will continue on this and a new time for trying updates will be announced asap.

Qt Creator 4.9.0 can't disable line annotations (ignores option)



  • No matter what I do in Tools->Options->Text Editor->Display, I can't seem to get rid of line annotations.

    I tried unchecking "line annotations" yet I'm still getting underlined warnings in the code as a result of the code model.

    I have the clang code model plugin disabled (when I tried it, I couldn't get it to disable erroneous warnings either, so I had to give up. Maybe that is a related problem?)

    Ubuntu 18.04
    Qt Creator about:
    Based on Qt 5.12.2 (GCC 5.3.1 20160406 (Red Hat 5.3.1-6), 64 bit)


  • Qt Champions 2018

    @justyn said in Qt Creator 4.9.0 can't disable line annotations (ignores option):

    No matter what I do in Tools->Options->Text Editor->Display, I can't seem to get rid of line annotations.

    I have the clang code model plugin disabled

    If you disable Clang, you may still get underlines from the Classic Code Model, but no annotations.

    Did you restart Creator after disabling Clang in Help > About Plugins > Clang Code Model? Also, if you have several Creator instances open, I recomment to close all except one before disabling the plugin.

    Regards



  • Oh okay, I had considered the underlining to be a type of line annotation, apparently that is not the case.

    It is the underlining I have a problem with - I use a lot of designated initialisers in C, like this:

    struct foo_s bar = {
      .x = 1,
    };
    

    They all end up underlined with the warning: "expected token ;...."

    So there is no way to disable the underlining?


Log in to reply