Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Same ol' "No valid kits" issue...



  • Okay, so I've seen this before but seem to be able to fix it (somehow) each time.
    This time, I'm stumped.

    So, here are the specs:

    1. Running Windows 10 (so please, no "just run sudo apt-get etc")
    2. I am installing Qt Creator 4.6.2 based on Qt 5.11.1
    3. I have installed a fresh install of MingW
    4. I have tried pointing it to both the pre-installed version of MingW and the newly-installed version from the MingW download manager.

    It keeps refusing to let me even create a project, claiming that there are no valid kits!
    The only field that I can't fill is "Version". All attempts lead me to the file tree looking for an unknown file.

    Please see screenshot.

    Thank you.


  • Moderators

    @Uberlinc said in Same ol' "No valid kits" issue...:

    Please see screenshot.

    there are no screenshots?

    Anyway. Try adding the "mingw32/bin" dir to the PATH variable, then it should be picked up by QtCreator automatically.
    In the settings simply make sure that all tabs (from right to left - leftmost tab is the Kits tab) have correct settings. And press apply whenever you changed something.



  • Thank you.
    I went to paste in a screenshot but the above button inserts some hypertext that implies that it wants a URL.
    As the image file is local on my machine, I have no actual way to post a link to a website.
    Can a simple image be uploaded?

    So, after reading your post, I went away and did what you said.
    No joy.

    So, now I completely reimaged my machine with a clean installation of Win 10 on it (in case all my mucking around mucked up all the settings.)
    Then, I downloaded and installed the basic MingW compiler.
    I placed "C:\MingW\bin" into the Win 10 path.
    I then installed Qt Creator.

    Same error.
    I get "No valid kits"
    Except that in this case, it has already chosen yet a different compiler (Clang, which appears to be bundled with the Qt Installation) but is complaining that I have no debugger.
    So, I searched and found the GNU CDB which was only a .exe file.
    I placed it in c:\mingw\cdg and placed that path into the Windows 10 PATH variable.
    I then says "The ABI of the selected debugger does not match the ABI of the toolchain."

    Is there a recommended debugger?
    Is there are recommended compiler (i.e. Separate installation of MingW or use the bundled Compiler?)

    Why must this be so difficult? I have installed this before at it auto-detects and works without a hitch! This time it is throwing curveball after curveball!

    Many thanks.


  • Lifetime Qt Champion

    @Uberlinc You should definitely use the MinGW bundled with the Qt online installer. Of course you have to select a fitting Qt MinGW version also.

    After that, you should be ready to go.

    For picture upload: try to paste it from the clipboard here ore use an external upload service and paste the link here.



  • Still no joy.
    This time, with a cleanly reimaged PC, I simply installed Qt (without anything else) and selected the MinGW 7.3.0 64 bit compiler and the "GNU gdb 8.1 for MinGW 7.3.0 64 bit" and still coming up with no valid kits.

    Note: This is a completely clean Windows 10 install with a completely clean Qt Online installation.
    It is still complaining that there are no valid kits.

    Below is (an attempt) to post a pic.

    alt text


  • Lifetime Qt Champion

    @Uberlinc Please show the tab Qt versions too. Thanks.

    Reason: In this kit, no Qt version is selected ("None").



  • I saw that!
    (You might notice that I mentioned it in an earlier post - but nobody seemed to twig.)

    When I tried to select, there is nothing in the drop-down list.
    When I hit "Manage", it presents a browse window .... and I don't know where to go from there.
    Suggestions?


  • Lifetime Qt Champion

    @Uberlinc Please show the Qt versions tab!

    If that one is empty, then you simply did not install a Qt version.

    Make sure to select a version that fits your compiler.



  • Yes, thank you for this!
    I now have it working.


  • Lifetime Qt Champion

    @Uberlinc Glad you got it working, and thanks for reporting back.

    Regards


Log in to reply