Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

[SOLVED] Upgrading to QtCreator 4.9.0 has broken my macOS Kit



  • Hi,
    I've come into work this morning and updated to QtCreator 4.9.0. Now it no longer detects my macOS 5.12.2 kit. If I enter "Manage Kits" i can see "Desktop Qt 5.12.2 clang 64bit" but it has the yellow warning /!\ icon next to it.

    I've tried uninstalling the kit through the Maintenance Tool and reinstalling it. While both of those actions are successful, QtCreator still does not allow me to use the kit.

    It's worth noting that "Android for armeabi-v7a 5.12.2" and "Qt 5.12.2 for iOS2" are detected and work just fine. This only appears to be an issue with the macOS kit.

    As this seriously affects my ability to do my job, I would appreciate any help with this matter. Thanks.



  • Apparently it just wiped the compilers I was using, and wiped the Build profiles.
    Once I selected "Apple Clang (x86_64)" for both C and C++ Compiler, I just had to add and configure my Debug and Release builds and it seems to work now.

    Still, this seems like an issue worth looking at if more people have their build settings wiped upgrading from QtCreator 4.8.x to 4.9.0.


Log in to reply