[Solved] Strange Qt Creator text search behaviour



  • I was having trouble finding some text in my code, so I delved into the issue a bit. It is very strange. If I search for each individual alphabet letter (lower case), I find that all can be found except 'e', 'g', 'o', 'q', 'u', and 'y'. But it's more complicated than that. For example, 'pr' is not found. 'oo' and 'ool' are not found, but 'bool' is found. I can see no rhyme or reason to the failures. There must be a logic to it - maybe somebody can tell me.

    BTW this is Qt Creator 2.0.1, based on Qt 4.7.0 (32-bit).



  • Cannot reproduce your problem, I'm using the same creator 2.0.1 on 4.7, search works fine. Did you try on another project? or restart creator? Not sure if while parsing/indexing something went wrong



  • The 'mystery' is easily solved. Someone, it appears, had selected 'Whole Words Only' in the search options. All the letters of the alphabet occur as words in the code file I was editing, except for those six.

    Very strange, since I'm the only one who uses this machine ... :-)



  • good to hear that :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.