QtWebengine 5.12.2 - Compiling from source (Mac OS X) with webengine-proprietary-codecs not working



  • Hi everyone,

    I've been trying to compile the new version of Qt 5.12.2 on Mac OS X with the option webengine-proprietary-codecs, however, I didn't succeed to pass it to any configure/qmake command (I'm using qt everywhere sources)

    I'm passing it to the top level configure:

    OPENSSL_LIBS='-L/usr/local/opt/openssl/lib -lssl -lcrypto' ./configure -webengine-proprietary-codecs -opensource -nomake examples -confirm-license -openssl-linked -I /usr/local/opt/openssl/include
    

    But the answer is:

    ERROR: Unknown command line option '-webengine-proprietary-codecs'.
    

    When I do a --help on configure, I can see it as one option available.

    I also tried to go to the qtwebengine subfolder and do:

    ../qtbase/bin/qmake -- -webengine-proprietary-codecs
    

    But the answer is:

    Project ERROR: You cannot configure qtwebengine separately within a top-level build.
    

    So why the top-level configure doesn't accept the option?

    I read a lot of things online, they are mostly about Windows and previous version of Qt, don't know if anything changed recently.

    Thanks for your help,



  • try this syntax

    ./configure -opensource -confirm-license -release -webengine-pepper-plugins -webengine-proprietary-codecs -no-openssl -securetransport -prefix /Users/mblais2/DEV2/v5.12.2
    
    


  • here is the full procedure in mac

    git clone git://code.qt.io/qt/qt5.git
    cd qt5
    --git checkout tag version, i.e : 
    git checkout v5.11.3
    perl init-repository --module-subset=all
     
    
    --configure, use another folder prefix on the same level as qt source
    ./configure -opensource -confirm-license -release -webengine-pepper-plugins -webengine-proprietary-codecs -no-openssl -securetransport -prefix /Users/mblais2/DEV2/v5.12.2
    
    
    make
    make install
    


  • Thank you @maximus, it worked very well with the git repository. I don't really know why it didn't work with the source for the archive but it doesn't really matter.

    I can confirm that the topic is resolved and this option worked as expected with this method.


 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.