Create SIS Package step fails for unsigned sis



  • Hi to all,

    I have a little question: I have updated - resinstalling it - the development environemnt iwth the last Qt SDK 1.3 including Qt Creator 2.3.0 and Qt 4.7.4 I need this version because it includes NFC support, best Harmattan support, CODA working correctly for symbian on-device debugging etc.

    Now I meet a problem that I have no idea of how I can solve. I can't deploy my symbian applicaitons in packages that can be passed by QA in Ovi Publish. The reason is clear as explained in the same publishers pages:

    bq. Note: The Qt 4.7.4 based bundle isn't currently support by Smart Installer for Symbian. Qt SDK has beta level support for this for development purposes. Qt 4.7.4 is being finalized for Smart Installer deployments for Symbian^3 and Symbian Anna devices at the moment and is expected to be released with Symbian Belle availability. (Symbian Belle has this Qt 4.7.4 based bundle in ROM.)

    So does anyone has a solution on how I can prepare a smart installer package with Qt 4.7.4 that can work and install the application in a user device ?

    Thank to any advice.



  • Hi,

    Our client needs an unsigned sis package to sign for themselves, the Create SIS Package step from project settings fails(after I've checked the 'not signed' radiobutton) with the following error message:
    @:-1: error: No rule to make target `unsigned_sis'. Stop.@

    It seems that the qmake fails to generate a proper Makefile. What could be causing this problem?

    Best regards



  • Hi, if you are using the Qt 4.7.4 it is explicitly told that it does not support the smartinstaller SIS package. If you send your sis package to the client (as is on a device that is not used for development) it is possible that you missed some components that will be usually delivered / installed by the smartinstaller package.

    Plesse let me know what is the current version of Qt you are using because the workaround are different.



  • I'm using Qt 4.7.4 and Symbian Belle as my target.

    When updating my SDK I did encounter some errors though, could that be it?



  • I was supposing it :)

    AS you can read in the Nokia notes about the 4.7.4 and smart installer (that can be extended to the general sis packages installation as I have seen until now)

    bq. Note: The Qt 4.7.4 based bundle isn't currently support by Smart Installer for Symbian. Qt SDK has beta level support for this for development purposes. Qt 4.7.4 is being finalized for Smart Installer deployments for Symbian^3 and Symbian Anna devices at the moment and is expected to be released together with Symbian Belle availability. (Symbian Belle has this Qt 4.7.4 based bundle in ROM.)

    You can find some general useful information about the versions and supported devices "here":http://www.developer.nokia.com/Community/Wiki/Nokia_Smart_Installer_for_Symbian.

    While respect the Qt SDK 1.1.3 current release and Qt 4.7.4 there is an exaustive note about the compatibility to this "link.":http://www.developer.nokia.com/Community/Wiki/Qt_SDK

    I agree that unfortunately because the Qt 4.7.4 is the only supporting symbian at the moment to be able to deliver and/or distribute Symbian Belle applicaitons on Ovi store we should wait until there is an update or a new release.

    Then always in the Nokia wiki page you can read the following

    bq. Limitations

    • To package applications for Symbian devices the Nokia Smart Installer for Symbian should be used.
    • Qt SDK online version reloads parts during compilation resulting in slow compilation.
    • On-device debugging - TRK is no longer supported by Qt Creator 2.3, you must update to CODA. Note, in addition, that CODA is not supported on S60 3rd Edition phones.* Qt 4.7.4 and Qt Mobility 1.2 - these are at beta level, applications created using these APIs cannot be submitted to Nokia Store. Nokia Store will accept such applications when the APIs exit beta.

    At this point I am curious to know what we can do to distribute Symbian Belle compatible aplications. If you notice something about this, please update this thread.



  • Related link with more details: http://developer.qt.nokia.com/forums/viewthread/10334/

    (probably these two posts can be merged in someway?)



  • I tried deploying with Qt SDK 1.1.1 and Qt 4.7.3, but the same error occurs.



  • If you change from 1.1.3 to some previous versions take in account the the projects are not compatible. You should recreate the project from scratch.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.