Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Windows deployment problems



  • Hello Community,
    I have a problem in deploying a qt quick application. If i run the application from qt qreator it works fine. After this i deployed the application with the windeployqt tool. If i double tab on the .exe the application won't start. If i run this .exe file from the qt commandline it starts without problems. If i run it from windows shell it also doesn't start.Dependency walker marks that the qcore.dll checksum is wrong.

    I am using win32 with qt 5.11.1.

    Do you have any suggestions?

    Best regards,
    Julian



  • I tried something more.
    If i copy the Whole bin folder from mingw32 from 11.1 into the folder from my Exe the Programm does start.
    But if i rename my Qt folder. So the system thinks i have no qt enviroment installed it doesn't start again.
    But in my enviroment variables there is nothing with qt



  • Sry was my fault. I Forgot to copy the qml folder.
    Now it works. And i can begin to remove everything what is not needed from the application


Log in to reply