@PaulR I don't do any "Qt web server app", so I don't know if that has any special requirements, but just to say I do all my Qt install stuff just from the release version for Ubuntu 18.04 via apt-get (including apt-get qt5-default, plus any extras I then find I need) and never do any source/compiling. Simplez :)