Hi and welcome to devnet, If possible, you should upgrade to 5.5, IIRC, there's been a lot of work done in the bluetooth module for it.