I have updated Qt to version 5.12.1 and IIRC never seen the message again. Therefore, I have checked and went back to target API level 24 and the message pops up again. Going back to API level 28, the message is coming anymore. I will stay so far with Qt 5.12.1