Nevermind tried again and it worked. So 5.3 does have the same problem as uwebkit in that macys gives the same error.

Next I tried to build the 5.5 fancybrowser.

and the same thing happens in both.