Simplest way to for loop
-
@jsulm said in Simplest way to for loop:
for (int a : {0, 1, 2, 3, 4, 5}) {}
How can i make a text macro to go for (int a : {0, 1, 2, 3, 4, 5......1000000}) {}?
@Q139 said:
How can i make a text macro to go for (int a : {0, 1, 2, 3, 4, 5......1000000}) {}?
You could use
std::iota
:) Just joking. Don't do it, it's a bad idea to create a static range of consecutive numbers just to iterate over it. It's a waste of cycles and memory. There's nothing wrong withfor(int a=0; a<b; a++);
. Don't go into macros. They'll save you few keystrokes and then add 100x that if you ever need to debug that loop. -
@Q139 said:
How can i make a text macro to go for (int a : {0, 1, 2, 3, 4, 5......1000000}) {}?
You could use
std::iota
:) Just joking. Don't do it, it's a bad idea to create a static range of consecutive numbers just to iterate over it. It's a waste of cycles and memory. There's nothing wrong withfor(int a=0; a<b; a++);
. Don't go into macros. They'll save you few keystrokes and then add 100x that if you ever need to debug that loop.@Chris-Kawa Why would it be significantly harder to debug?
-
@Chris-Kawa Why would it be significantly harder to debug?
@Q139 I overshot with the 100x for dramatic effect ;) It's harder because you can clearly see the current value of a in the debugger (it's even in the tooltip on hover in QtCreator or VS). With macro you can do it too of course, but if you see the macro for the first time it looks like a function, so you need to go to its implementation, look up what's the name of the counter variable and then look that up in the debugger.
There's also the readability problem. Remember that you'll write this once and then it will be read a lot of times so making it readable should take priority over saving few keystrokes now and then. Most IDEs even have a snippet for this so you can make a for loop with a shortcut so that's not even saving you from typing that much.
Your example also shows another problem with this. To use the counter in the for body you need to know that the macro defines a counter that is calledi
. If you don't know that you need to look it up and someone reading it doesn't know whati
is at first glance. Also "Go to definition" will take you to the macro invocation which is just not helpful.I just can't see any compelling reason to use a macro in this case. What does it give you or your readers?
-
@Q139 I overshot with the 100x for dramatic effect ;) It's harder because you can clearly see the current value of a in the debugger (it's even in the tooltip on hover in QtCreator or VS). With macro you can do it too of course, but if you see the macro for the first time it looks like a function, so you need to go to its implementation, look up what's the name of the counter variable and then look that up in the debugger.
There's also the readability problem. Remember that you'll write this once and then it will be read a lot of times so making it readable should take priority over saving few keystrokes now and then. Most IDEs even have a snippet for this so you can make a for loop with a shortcut so that's not even saving you from typing that much.
Your example also shows another problem with this. To use the counter in the for body you need to know that the macro defines a counter that is calledi
. If you don't know that you need to look it up and someone reading it doesn't know whati
is at first glance. Also "Go to definition" will take you to the macro invocation which is just not helpful.I just can't see any compelling reason to use a macro in this case. What does it give you or your readers?
@Chris-Kawa
Defining variable name to macro might help readability if debugger displays variables well.#define afor(v,max) for(int v=0; v<max; v++) afor(i,3) infoLine(n(c[i]));
Was also looking into macros support for text manipulation to make macro like
afor(i=1,3)
but it appears only avalible option is##
that appends text of macro function parameters
So just replaced = with comma and used 3 paramaters#define afor(v,min,max) for(int v=min; v<max; v++) afor(i,1,3)
Qt debugger displays variable value easyer now.
Only problem is that if i have 2 or more #defines with same name but dif argument lengths it wont find correct macro by arg length, it chooses last defined one. -
@Chris-Kawa
Defining variable name to macro might help readability if debugger displays variables well.#define afor(v,max) for(int v=0; v<max; v++) afor(i,3) infoLine(n(c[i]));
Was also looking into macros support for text manipulation to make macro like
afor(i=1,3)
but it appears only avalible option is##
that appends text of macro function parameters
So just replaced = with comma and used 3 paramaters#define afor(v,min,max) for(int v=min; v<max; v++) afor(i,1,3)
Qt debugger displays variable value easyer now.
Only problem is that if i have 2 or more #defines with same name but dif argument lengths it wont find correct macro by arg length, it chooses last defined one.afor(i,1,3)
vs
for(int i=1; i<3; ++i)
Just my personal opinion but I think you're overdoing it. It's just not worth it.
afor
looks likeatoi
or some such function. It's misleading. It hinders even basic tasks like scanning visually for loops and whiles when you're looking for basic complexity markers in your code.
I mean go through say 50 random projects on github. I bet you none of them will try to obscure a for loop, basic language construct. -
@Q139 The general advice is to not use any macros in your code. There are a few exceptions to this rule. I personally like X macros for a few use cases. Also if I have a lot of repeated code that cannot be easily factored out into a function (switch over enums and types, ...) I do use macros. Repeated similar code also appears when overloading
operator+
,operator-
and so on for a user-defined type.However, in your case you are using a macro
afor
to introduce new syntax. This will make your code unreadable for anybody else (possibly also include the very popular 'future self').The major question usually is if you really need the running index. For your tiny example iteration over
infoLine(n(c[i]))
you can rewrite it to a range-based for loop:for(const auto &a : c) infoLine(n(a));
There are few cases where you actually need an actual index. C++20 helps out with this a little bit. You can now write:
for(int i = 0; const auto &a : c) { infoLine(n(a)); ... ++i; }
Personally, with a all the new features of C++20, like ranges and generators, I would really like to see someone implement something like this:
for(int i : "[0..10)"_rng) // numbers 0 through 9 ... for(int i : "[1..10]"_rng) // numbers 1 through 10 ...
-
If you really want ranges then use boost:range
C++ will eventually get ranges. So you are future proofing your code for minimal changes. -
@Q139 The general advice is to not use any macros in your code. There are a few exceptions to this rule. I personally like X macros for a few use cases. Also if I have a lot of repeated code that cannot be easily factored out into a function (switch over enums and types, ...) I do use macros. Repeated similar code also appears when overloading
operator+
,operator-
and so on for a user-defined type.However, in your case you are using a macro
afor
to introduce new syntax. This will make your code unreadable for anybody else (possibly also include the very popular 'future self').The major question usually is if you really need the running index. For your tiny example iteration over
infoLine(n(c[i]))
you can rewrite it to a range-based for loop:for(const auto &a : c) infoLine(n(a));
There are few cases where you actually need an actual index. C++20 helps out with this a little bit. You can now write:
for(int i = 0; const auto &a : c) { infoLine(n(a)); ... ++i; }
Personally, with a all the new features of C++20, like ranges and generators, I would really like to see someone implement something like this:
for(int i : "[0..10)"_rng) // numbers 0 through 9 ... for(int i : "[1..10]"_rng) // numbers 1 through 10 ...
@SimonSchroeder said in Simplest way to for loop:
Personally, with a all the new features of C++20, like ranges and generators, I would really like to see someone implement something like this:
for(int i : "[0..10)"_rng) // numbers 0 through 9
...
for(int i : "[1..10]"_rng) // numbers 1 through 10
...Ah, the C++ code is JavaScript argument. Well, I really wish someone wouldn't.
auto
is terrible enough on its own, I personally don't need even more vague headaches. -
@Q139 The general advice is to not use any macros in your code. There are a few exceptions to this rule. I personally like X macros for a few use cases. Also if I have a lot of repeated code that cannot be easily factored out into a function (switch over enums and types, ...) I do use macros. Repeated similar code also appears when overloading
operator+
,operator-
and so on for a user-defined type.However, in your case you are using a macro
afor
to introduce new syntax. This will make your code unreadable for anybody else (possibly also include the very popular 'future self').The major question usually is if you really need the running index. For your tiny example iteration over
infoLine(n(c[i]))
you can rewrite it to a range-based for loop:for(const auto &a : c) infoLine(n(a));
There are few cases where you actually need an actual index. C++20 helps out with this a little bit. You can now write:
for(int i = 0; const auto &a : c) { infoLine(n(a)); ... ++i; }
Personally, with a all the new features of C++20, like ranges and generators, I would really like to see someone implement something like this:
for(int i : "[0..10)"_rng) // numbers 0 through 9 ... for(int i : "[1..10]"_rng) // numbers 1 through 10 ...
@SimonSchroeder said:
Personally, with a all the new features of C++20, like ranges and generators, I would really like to see someone implement something like this:
I was bored :P
auto operator"" _rng(const char* str, size_t len) { int start = atoi(str+1); int end = atoi(strrchr(str, '.') + 1); if (*str == '(') ++start; if (*(str+len-1) == ']') ++end; return ranges::views::iota(start, end); } int main() { for (auto i : "[1..10)"_rng) { std::cout << i << '\n'; } }
Please don't ever use this anywhere. No, seriously. It's a horrible waste.
-
#define el(t) errorLine(t) #define il(t) infoLine(t) #define vo void #define re return #define ei else if #define el else #define w(c) while(c) //for loops zero index based #define f0(v,max) for(int v=0; v<max; v++) #define f(v,min,max) for(int v=min; v<max; v++) #define fRev(v,min,max) for(int v=max-1; v>=min; v--) #define fa(v,c) for(auto v:c) //data types #define D double #define F float //int types #define I int #define UI unsigned int #define L long int #define UL unsigned long int #define I64 qint64 #define I32 qint32 #define I16 qint16 #define U64 quint64 #define U32 quint32 #define U16 quint16 #define C char #define UC unsigned char #define B bool
I tryed coding with those , in some places i think it can actually increase readability ,if familiar with the macros.
Also single letter capital variable types make code look cleaner.
If i continue adding stuff some point 1-2 letter combos will run out and will have to start using more keystrokes. -
#define el(t) errorLine(t) #define il(t) infoLine(t) #define vo void #define re return #define ei else if #define el else #define w(c) while(c) //for loops zero index based #define f0(v,max) for(int v=0; v<max; v++) #define f(v,min,max) for(int v=min; v<max; v++) #define fRev(v,min,max) for(int v=max-1; v>=min; v--) #define fa(v,c) for(auto v:c) //data types #define D double #define F float //int types #define I int #define UI unsigned int #define L long int #define UL unsigned long int #define I64 qint64 #define I32 qint32 #define I16 qint16 #define U64 quint64 #define U32 quint32 #define U16 quint16 #define C char #define UC unsigned char #define B bool
I tryed coding with those , in some places i think it can actually increase readability ,if familiar with the macros.
Also single letter capital variable types make code look cleaner.
If i continue adding stuff some point 1-2 letter combos will run out and will have to start using more keystrokes.@Q139
I don't mean to be rude, and of course your code is up to you, but I think you will be the only person to find these macros "clearer". I would simply class them as "dangerous" --- goodness knows what you might "break" by defining single- or even two-character sequences as macros. And you are overloading, say,el
versusel(t)
to do completely different things. On top of everything, have you looked whether you will break, say, Qt Creator's auto-completion or folding etc. with these definitions?This is just not the C++ way to do things. Up to you.
-
#define el(t) errorLine(t) #define il(t) infoLine(t) #define vo void #define re return #define ei else if #define el else #define w(c) while(c) //for loops zero index based #define f0(v,max) for(int v=0; v<max; v++) #define f(v,min,max) for(int v=min; v<max; v++) #define fRev(v,min,max) for(int v=max-1; v>=min; v--) #define fa(v,c) for(auto v:c) //data types #define D double #define F float //int types #define I int #define UI unsigned int #define L long int #define UL unsigned long int #define I64 qint64 #define I32 qint32 #define I16 qint16 #define U64 quint64 #define U32 quint32 #define U16 quint16 #define C char #define UC unsigned char #define B bool
I tryed coding with those , in some places i think it can actually increase readability ,if familiar with the macros.
Also single letter capital variable types make code look cleaner.
If i continue adding stuff some point 1-2 letter combos will run out and will have to start using more keystrokes.@Q139 said in Simplest way to for loop:
I tryed coding with those , in some places i think it can actually increase readability ,if familiar with the macros.
@JonB said in Simplest way to for loop:
This is just not the C++ way to do things.
This is not even the C way to do things, that's simply trying to reinvent the language by means of the preprocessor, what could possibly go wrong ...
-
Reminds me of a guy that transitioned form Pascal to C++ and first thing he did was define bunch of macros like
#define begin { #define end } #define procedure void
If you decided to code in C++ code in C++. I completely agree with @kshegunov . Using preprocessor to reinvent the language is just straight up horrible.
-
Reminds me of a guy that transitioned form Pascal to C++ and first thing he did was define bunch of macros like
#define begin { #define end } #define procedure void
If you decided to code in C++ code in C++. I completely agree with @kshegunov . Using preprocessor to reinvent the language is just straight up horrible.
@Chris-Kawa I used to code a lot in Borland Pascal + TASM back in '90 but I would not even consider such... THING as the above. That's truly WAT moment for me.
-
@JonB said in Simplest way to for loop:
On top of everything, have you looked whether you will break, say, Qt Creator's auto-completion or folding etc. with these definitions?
Project 35k lines ,no problems so far.If I continue adding macros at some point I would need a converter to detect the macros and convert to clean code.
It is sad that precompiler fails if adding other preprocessor macros like
#define ompFor #pragma omp parrallel for schedule(dynamic)
-
@JonB said in Simplest way to for loop:
On top of everything, have you looked whether you will break, say, Qt Creator's auto-completion or folding etc. with these definitions?
Project 35k lines ,no problems so far.If I continue adding macros at some point I would need a converter to detect the macros and convert to clean code.
It is sad that precompiler fails if adding other preprocessor macros like
#define ompFor #pragma omp parrallel for schedule(dynamic)
@Q139
Hi
Creator has a very good refactor function.
https://doc.qt.io/qtcreator/creator-editor-refactoring.htmlAlso, if you tried this due to being tired of typing something always, please notice
that Creator can help with its auto text.
Pressing ctrl+space allows you to insert for loop , all ready to name it
and so on.Trust me when i say you dont really want to use macros to change the core language. Been there, done that and it was not a good idea. One year later when i looked at the project, then suddenly it was not so clear anymore and that is actually how most people see it right away. :)
-
@Q139
Hi
Creator has a very good refactor function.
https://doc.qt.io/qtcreator/creator-editor-refactoring.htmlAlso, if you tried this due to being tired of typing something always, please notice
that Creator can help with its auto text.
Pressing ctrl+space allows you to insert for loop , all ready to name it
and so on.Trust me when i say you dont really want to use macros to change the core language. Been there, done that and it was not a good idea. One year later when i looked at the project, then suddenly it was not so clear anymore and that is actually how most people see it right away. :)
-
@mrjj Is it possible to set refactor to start at 2 letters instead of 3?
I know it is bad idea due to exponentially increasing results etc..
Never saw for refactor , never pressed the ctrl+space on purpose.@Q139
Hi
Well the auto code text thing can trigger on any keyword and with length 1 i think
For refactor, its a super search and replace basically but it does know the real type so its smarter then
plain text replace. (to show only the right ones) -
For most programmers I have met, macro programming is considered something you should avoid unless you have a specific need. Learn the language and learn the libraries. You will find that you don't need macros. You will eventually run into a coder reviewer and they will not be happy with excessive macro usage. Macros have logic bombs that appear to be evaluated differently than you might expect. I would suggest researching why people avoid macros in the first place. You would do better to learn about templating to customize things. For instance you could use templating to make your own range class that allows iteration using for(auto i: items(0,10,1)). Where items is a templated class.