Jak zainstalować QT 5.10 ?



  • Witam,
    Na wstępie dodam, że dopiero rozpoczynam przygodę z okienkami, a Qt miał być moją 1 apką, więc nie wiem jak powinien wyglądać proces instalacji.

    Dziś przez kilka godzin próbowałem zainstalować QT ( wersja Open Source), pobrałem instalator odpaliłem, nie zmieniałem NIC podczas instalacji.Gdy próbowałem stworzyć projekt na pewnym etapie dostałem monit:
    Brak poprawnych zestawów narzędzi.
    ( włączyłem opcje debugowania, jako kompilator był wskazany mingw, przy qmake nie miałem żadnych opcji wyboru)

    Poczytałem troszeczkę wywnioskowałem że nie zainstalowałem kompilatora ( dodam że posiadam kompilator MinGW bo używam CodeBlocks'a ), pobrałem inną wersję QT:
    http://download.qt.io/official_releases/qt/5.6/5.6.3/qt-opensource-windows-x86-mingw492-5.6.3.exe

    Tutaj projekt mogłem utworzyć, niestety program się nie wyświetlał ( próbowałem każdą opcję chyba / nie wiem czy to ma znaczenie ale przy debugowaniu w rogu wyświetlał się czerwony pasek).

    Kolejny raz usunąłem QT, odpaliłem instalator ( ten aktualny) tym razem zaznaczyłem opcję QT 5.10, tutaj dostałem monit że użyte zostanie ponad 30 GB dysku, co przy moim interecie jest niemożliwe do pobrania na raz ( dziwna sprawa bo prędkość przy pobieraniu pakietów była < 400 KB/s).

    Możecie coś poradzić?


  • Moderators

    @BiayKruk said in Jak zainstalować QT 5.10 ?:

    Kolejny raz usunąłem QT, odpaliłem instalator ( ten aktualny) tym razem zaznaczyłem opcję QT 5.10, tutaj dostałem monit że użyte zostanie ponad 30 GB dysku, co przy moim interecie jest niemożliwe do pobrania na raz ( dziwna sprawa bo prędkość przy pobieraniu pakietów była < 400 KB/s).

    Nie zaznaczaj całego Qt 5.10. Wystarczy jedna wersja, nie potrzebujesz też paczek modułów (Qt Charts itd.), nie potrzebujesz paczek MSVC, kodu źródłowego Qt, paczek Android ani róznych wariantów jak WinRT itd.

    Wystarczy jeden checkbox zaznaczyć z Qt @ MinGW, do tego w Tools wybrać odpowiednia wersję MinGW.

    Sorry że tak ogólnikowo piszę ale akurat nie mam kompa z windowsem pod ręką.



  • 0_1522076177786_1.png

    Mógłbyś pomóc ? Tak to wygląda w instalatorze.


  • Moderators

    Ło masakra jak to się rozrosło :-)

    Powinno wystarczyć jak zaznaczysz do instalacji tylko:

    • Qt 5.10.1 / MinGW 5.3.0 32 bit
    • Tools / MinGW 5.3.0

Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.