Qmodbus -- libmodbus -- linux



  • Ciao a tutti,

    fino alla qt5.6 avevo inteso che per avere qmodbus funzionante su pc linux fosse necessario installare libmodbus .... la libreria che pure funziona molto bene ha alcune limitazioni sospratutto per quel che riguarda i messaggi broadcast ... tutto il resto invece funziona molto bene e anzi sono ora disponibili funzioni "avanzate" come le macro per le conversioni di numeri decimali esadecimali nella trasmissione a doppio registro... la trasmissione tcp che mi risulti in broadcast funziona bene ... ma ha problemi per quel che riguarda le disconnessioni accidentali e relative riconnessioni ...
    Ora non ho trovato documenti che consigliassero di installare libmodbus nelle versioni di QT5.8 ... significa che ora le qt hanno la loro propria specifica libreria per il modbus??



  • @gfxx mi rispondo avendo testato ... funzionano anche molto bene.

    ciao a tutti


Log in to reply