Error en instalacion QT5 para Raspberry 3 con compilacion cruzada



  • hola.
    Estoy intentando instalar QT5 para Raspberry PI3 con compilación cruzada, según las instrucciones de este post, y me da el error de la imagen. ¿ alguien sabe cual puede ser el problema ?.

    https://forum.qt.io/topic/68381/cross-compile-qt-windows-to-raspberry-3

    Lo hago como Administrador y he cambiado los permisos a todos los archivos para que sean accesibles a todos los usuarios, pero sigo con el mismo error.

    O si alguien sabe alguna otra forma de instalar y configurar QT5 para Raspberry Pi 3 con compilación cruzada. Gracias y saludos.

    alt text



  • Yo tras probar varios tutoriales sin exito decidí instalar Qt en la raspberry y compilar allí los fuentes. Sin ningun problema.

    Lo único que la última versión de Qt para Rasberry Pi 3 con raspbian creo que es la 5.3.2 y me obliga a utilizar también esa en el PC donde programo.

    Pero salvo eso, ha sido la solución más rápida y sencilla. Siempre que tengas una Raspberry a mano, claro.



  • Hola,

    El problema es claro: desde tu ordenador WIndows no puedes acceder a la RaspberriPi.

    • Revisa que la IP sea correcta y que puedas usar ssh desde tu windows (ese firewall de Windows!)
    • Revisa que el usuario sea el correcto
    • Revisa que el Password sea el correcto.

    Suerte!



  • @Janjio hola. ¿ te funciona el Debug ?.
    A mi me va todo, salvo el Debug, me saca un mensaje de error que el GDB no soporta scrypts Python.



  • Hola pinballsp , a mi el debug me funciona correctamente en raspberry y en mi pc. Solo que yo programo en C++ y todo lo hago bajo Linux. Quizás alguien que trabaje con windows pueda ayudarte.
    Mirate este post donde lo solucionan instalando un GDB con soporte para python. Lo malo es que la solución que dan es para linux. Busca si hay una version para Windows.
    Yo hace ya muchos años que no trabajo con windows asi que no puedo ayudarte en eso.

    Un saludo


Log in to reply