RaspberryPi2EGLFS Tutorial configure fails RaspberryPi2EGLFS



  • Hi,

    I followed everything in the RaspberryPi2EGLFS tutorial and tried to install qt 5.6 (tried 5.7 as well). When doing the ./configure I get the following Error ( http://pastebin.com/BciNARWM ). The problem is basically that almost everything fails in configure. It gives me:
    Unable to determine architecture!

    And finally stops at:
    OpenGL ES 2.0 disabled.
    The OpenGL ES 2.0 functionality test failed!

    Is there a workaround?
    As host (where I typed this command), Im using Ubuntu. As slave, Im using the Raspberry Pi 3 with Jessie lite.

    thank you!

    EDIT: Fixed it by following this guide:
    https://wiki.qt.io/Raspberry_Pi_Beginners_Guide#Getting_Could_not_determine...
    which recommends installing lib32z1-dev :)



  • Sorry for the doublepost. I got it to work! The sample works. Now I tried to compile a QTquick app, but it looks like qmake cant find the proper module.

    virtualuser@VirtualBox:~/mEICAS$ ~/raspi/qt5/bin/qmake -r
    Project ERROR: Unknown module(s) in QT: qml quick

    mEICAS is my project folder.

    EDIT: Got this working as well, compiled qt5 instead of qtbase. Now I got all the plugins!


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.