Qt5 development primer



  • Hi, trying to build qtbase on WinXP using MSVC2008, followed the instructions exactly and it builds OK, but when when I try to run I get:

    "Failed to load platform plugin "". Available platforms are: windows:

    Any hints?



  • I am trying to build the qt5-alpha source from the zip download as I don't have git on my windows machine. Is there any way to do a "make clean"/"make confclean" without git?



  • I just happened to notice your posts - I didn't get an email notification.

    According to configure, "To reconfigure, run 'make confclean' and 'configure'.".
    Well you probably know that at least with Qt5 alpha, that doesn't work.

    I'm on Debian so I can't offer any Windows wisdom, but for "make clean" I just delete the directory and re-unpack the alpha .tar.bz2 again.

    I'm in the dark as to how to build/use the QtDeclarative component.
    It appears that the header I'm looking for - "QtDeclarative/QDeclarativeComponent" isn't installed although it's in the source tree - yes I built/installed qtjsbackend and qtdeclarative.

    Also, it would be nice if Qt5 beta had a top-level makefile that included targets for
    linux-x86-32-gcc-x11
    linux-x86-64-gcc-x11
    windows7-64-msvc2010

    and so on, so we could be sure we're building against a known and tested build configuration.

    And yes, it should fail if any prerequisites are missing (and maybe print warnings if they are different versions).



  • Hi All,

    I'm trying to building Qt5 om Mac OSX 10.7. Following the instructions given here:

    http://qt-project.org/wiki/Building_Qt_5_from_Git

    However, I'm running into an issue in the build-step which I'm not
    sure how to solve. One of the errors I'm getting is the following:

    gcc: error: tools/qlocale_mac.mm: Objective-C++ compiler not installed
    on this system

    I will give a detailed step-by-step descriptions of my process below,
    assuming the starting point to be a blank shell with PWD=$HOME:

    (1) git clone git://gitorious.org/qt/qt5.git qt5 [check!]

    (2) cd qt5 [check!] :)

    (3) perl init-repository --no-webkit [check! Does its job without complaining. I can provide the log if necessary]

    (4) unset QTDIR [check!] :)

    (5) export PATH="$PWD/qtbase/bin:$PWD/qtrepotools/bin:$PATH" [check!] :)

    (6) ./configure -developer-build -opensource -nomake examples -nomake
    tests [check! See below]

    Get a few warnings about some Qt header not containing macros, e.g.:

    QtCore: WARNING:
    /Users/thinks/qt5/qtbase/src/corelib/qtcoreversion.h does
    not include QT_BEGIN_HEADER

    but they don't seem severe. Other relevant output:

    Build type: macx-clang
    Architecture: x86_64
    Host architecture: x86_64
    Platform notes:

    • Also available for Mac OS X: macx-g++

    (7) ./build -j 4

    This is where the trouble begins. The following (first) error is given:

    [Lots of output without errors...]
    qabstractanimation.h -o .moc/debug-shared/moc_qabstractanimation.cpp
    gcc: error: tools/qlocale_mac.mm: Objective-C++ compiler not installed
    on this system
    gcc: error: kernel/qcore_mac_objc.mm: Objective-C++ compiler not
    installed on this system

    Similar errors are reported further on as well, all with the same
    reason given. It seems somewhat strange that gcc is used over g++, but
    at the moment I'm not really sure why this happens.

    Some info about gcc:

    [thinks@wiggs ~] gcc --version
    gcc (GCC) 4.8.0 20120408 (experimental)

    Any advice greatly appreciated!

    Thanks,

    T



  • @thinks, did you try to "build the 5.0 alpha":http://qt-project.org/wiki/Qt-5-Alpha-building-instructions instead? Might be easier than building from git.



  • Thanks, Ludde! :)

    We finally got it working here. The following was required:

    • Grab latest from Qt5 git repo.
      git clone git://gitorious.org/qt/qt5.git qt5

    • Use Qt's provided tool to initialize the repo.
      cd qt5
      perl init-repository --no-webkit

    • Set up our build environment.
      unset QTDIR
      export PATH="$PWD/qtbase/bin:$PWD/qtrepotools/bin:$PATH"
      export PATH=/Applications/XCode.app/Contents/Developer/usr/bin:$PATH
      export CPP=clang++
      export CC=clang
      echo PATH $PATH

    • Pre-build configuration. Note that we are forcing it to build using
      the Xcode compilers.
      ./configure -no-pch -developer-build -confirm-license -opensource
      -release -nomake demos -nomake examples -arch x86 -sdk
      /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.7.sdk

    • Build. We could increase the number of course to improve speed once
      we are convinced that this works well...
      ./build -j 1

    Not sure all of that stuff is required though, but because the build time is quite steep (even with j > 1) we didn't have time to narrow it down.

    Cheers,

    T



  • hi .

    I am currently doing the Qt5 manipulation and I have one little question ^^ .

    Is it possible to realize a configuration (./configure) in static Qt5 mode (-static) by incorporing the QtSerialPort class, which we must add to our pre-existing library thanks to that manipulation: http://qt-project.org/wiki/QtSerialPort ?

    If this is not possible to change QtSerialPort in static library, but just the QT5 library . When I will compile my project which uses QtSerialPort, will it run like a static program or I need to include a .so (or dll) ?

    Sorry for my bad english .



  • I am having trouble building Qt5......

    I have Visual Studio 2008 andf have installed the latest SDK......

    C:\qt5>configure -developer-build -opensource -nomake examples -nomake tests

    • C:/qt5/qtbase/configure -developer-build -opensource -nomake examples -nomake
      tests
      Please wait while bootstrapping configure ...

    Microsoft (R) Program Maintenance Utility Version 6.00.8168.0
    Copyright (C) Microsoft Corp 1988-1998. All rights reserved.

        cl -c -Yc -nologo -Zm200 -Zc:wchar_t -MT -W3 -GR -EHsc -w34100 -w34189
    

    -DUNICODE -DQT_NODLL -DQT_NO_CODECS -DQT_NO_TEXTCODEC -DQT_NO_UNICODETABLES -DQT
    _LITE_COMPONENT -DQT_NO_COMPRESS -DQT_NO_THREAD -DQT_NO_QOBJECT -DQT_NO_GEOM_VAR
    IANT -D_CRT_SECURE_NO_DEPRECATE -DQT_BOOTSTRAPPED -DCOMMERCIAL_VERSION -I"....
    include" -I"....\include\QtCore" -I"....\include\QtCore\5.0.0" -I"....\includ
    e\QtCore\5.0.0\QtCore" -I"C:\qt5\qtbase\tools\shared" -I"C:\qt5\qtbase\mkspecs\w
    in32-msvc2008" -Fpconfigure_pch.pch -Foconfigure_pch.obj -TP C:\qt5\qtbase\tools
    \configure\configure_pch.h

    Command line warning D4002 : ignoring unknown option '-Zc'
    Command line warning D4002 : ignoring unknown option '-Z:'
    Command line warning D4002 : ignoring unknown option '-Zw'
    Command line warning D4002 : ignoring unknown option '-Zc'
    Command line warning D4002 : ignoring unknown option '-Zh'
    Command line warning D4002 : ignoring unknown option '-Zr'
    Command line warning D4002 : ignoring unknown option '-Z_'
    Command line warning D4002 : ignoring unknown option '-Zt'
    Command line warning D4002 : ignoring unknown option '-w34100'
    Command line warning D4002 : ignoring unknown option '-w34189'

    configure_pch.h
    ....\include\QtCore../../src/corelib/global/qglobal.h(45) : fatal error C1083:
    Cannot open include file: 'stddef.h': No such file or directory
    NMAKE : fatal error U1077: 'cl' : return code '0x2'
    Stop.
    *** qtbase/configure exited with non-zero status.



  • I have a proble compiling Qt5 master recently
    (Linux x86_64 Mageia, GCC 4.7.1)

    make[2] : on entre dans le répertoire « /home/qtdev/srcs/qt5/qtsystems/src/systeminfo »
    g++ -c -m64 -pipe -g -std=c++0x -fvisibility=hidden -fvisibility-inlines-hidden -Wall -W -D_REENTRANT -fno-exceptions -fPIC -DQT_SHARED -DQT_COMPILER_SUPPORTS_SSE2 -DQT_COMPILER_SUPPORTS_SSE3 -DQT_COMPILER_SUPPORTS_SSSE3 -DQT_COMPILER_SUPPORTS_SSE4_1 -DQT_COMPILER_SUPPORTS_SSE4_2 -DQT_COMPILER_SUPPORTS_AVX -DQT_COMPILER_SUPPORTS_AVX2 -DQT_BUILD_SYSTEMINFO_LIB -DQT_MAKEDLL -DQT_NO_CAST_TO_ASCII -DQT_ASCII_CAST_WARNINGS -DQT_MOC_COMPAT -DQT_USE_QSTRINGBUILDER -DQT_DEPRECATED_WARNINGS -DQT_NO_MTLIB -DQT_NO_SFW_NETREG -DQT_NO_OFONO -DQT_NO_UDISKS -DQT_NO_LIBSYSINFO -DQT_QML_LIB -DQQmlImageProvider=QQuickImageProvider -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -DQT_NO_EXCEPTIONS -D_LARGEFILE64_SOURCE -D_LARGEFILE_SOURCE -I/home/qtdev/mkspecs/default -I. -I/home/qtdev/include/QtCore -I/home/qtdev/include/QtGui -I/home/qtdev/include/QtNetwork -I/home/qtdev/include -I/home/qtdev/include/QtQml -I/home/qtdev/include/QtJsonDb -I../../include/QtSystemInfo/5.0.0 -I../../include/QtSystemInfo/5.0.0/QtSystemInfo -I../../include -I../../include/QtSystemInfo -I../../include -I.rcc/debug-shared -I.moc/debug-shared -o .obj/debug-shared/qnetworkinfo_linux.o qnetworkinfo_linux.cpp
    In file included from qnetworkinfo_linux.cpp:56:0:
    /usr/include/bluetooth/bluetooth.h: In function ‘uint64_t bt_get_le64(const void*)’:
    /usr/include/bluetooth/bluetooth.h:159:9: erreur: expected identifier before ‘’ token
    /usr/include/bluetooth/bluetooth.h:159:9: erreur: expected ‘,’ or ‘...’ before ‘(’ token
    /usr/include/bluetooth/bluetooth.h:159:9: erreur: expected ‘;’ at end of member declaration
    /usr/include/bluetooth/bluetooth.h:159:9: erreur: ‘__v’ does not name a type
    /usr/include/bluetooth/bluetooth.h:159:9: erreur: ‘typeof’ was not declared in this scope
    /usr/include/bluetooth/bluetooth.h:159:9: erreur: ‘struct bt_get_le64(const void
    )::<anonymous>’ has no member named ‘__v’
    /usr/include/bluetooth/bluetooth.h: In function ‘uint64_t bt_get_be64(const void*)’:
    /usr/include/bluetooth/bluetooth.h:164:9: erreur: expected identifier before ‘’ token
    /usr/include/bluetooth/bluetooth.h:164:9: erreur: expected ‘,’ or ‘...’ before ‘(’ token
    /usr/include/bluetooth/bluetooth.h:164:9: erreur: expected ‘;’ at end of member declaration
    /usr/include/bluetooth/bluetooth.h:164:9: erreur: ‘__v’ does not name a type
    /usr/include/bluetooth/bluetooth.h:164:9: erreur: ‘typeof’ was not declared in this scope
    /usr/include/bluetooth/bluetooth.h:164:9: erreur: ‘struct bt_get_be64(const void
    )::<anonymous>’ has no member named ‘__v’
    /usr/include/bluetooth/bluetooth.h: In function ‘uint32_t bt_get_le32(const void*)’:
    /usr/include/bluetooth/bluetooth.h:169:9: erreur: expected identifier before ‘’ token
    /usr/include/bluetooth/bluetooth.h:169:9: erreur: expected ‘,’ or ‘...’ before ‘(’ token
    /usr/include/bluetooth/bluetooth.h:169:9: erreur: expected ‘;’ at end of member declaration
    /usr/include/bluetooth/bluetooth.h:169:9: erreur: ‘__v’ does not name a type
    /usr/include/bluetooth/bluetooth.h:169:9: erreur: ‘typeof’ was not declared in this scope
    /usr/include/bluetooth/bluetooth.h:169:9: erreur: ‘struct bt_get_le32(const void
    )::<anonymous>’ has no member named ‘__v’
    /usr/include/bluetooth/bluetooth.h: In function ‘uint32_t bt_get_be32(const void*)’:
    /usr/include/bluetooth/bluetooth.h:174:9: erreur: expected identifier before ‘’ token
    /usr/include/bluetooth/bluetooth.h:174:9: erreur: expected ‘,’ or ‘...’ before ‘(’ token
    /usr/include/bluetooth/bluetooth.h:174:9: erreur: expected ‘;’ at end of member declaration
    /usr/include/bluetooth/bluetooth.h:174:9: erreur: ‘__v’ does not name a type
    /usr/include/bluetooth/bluetooth.h:174:9: erreur: ‘typeof’ was not declared in this scope
    /usr/include/bluetooth/bluetooth.h:174:9: erreur: ‘struct bt_get_be32(const void
    )::<anonymous>’ has no member named ‘__v’
    /usr/include/bluetooth/bluetooth.h: In function ‘uint16_t bt_get_le16(const void*)’:
    /usr/include/bluetooth/bluetooth.h:179:9: erreur: expected identifier before ‘’ token
    /usr/include/bluetooth/bluetooth.h:179:9: erreur: expected ‘,’ or ‘...’ before ‘(’ token
    /usr/include/bluetooth/bluetooth.h:179:9: erreur: expected ‘;’ at end of member declaration
    /usr/include/bluetooth/bluetooth.h:179:9: erreur: ‘__v’ does not name a type
    /usr/include/bluetooth/bluetooth.h:179:9: erreur: ‘typeof’ was not declared in this scope
    /usr/include/bluetooth/bluetooth.h:179:9: erreur: ‘struct bt_get_le16(const void
    )::<anonymous>’ has no member named ‘__v’
    /usr/include/bluetooth/bluetooth.h: In function ‘uint16_t bt_get_be16(const void*)’:
    /usr/include/bluetooth/bluetooth.h:184:9: erreur: expected identifier before ‘’ token
    /usr/include/bluetooth/bluetooth.h:184:9: erreur: expected ‘,’ or ‘...’ before ‘(’ token
    /usr/include/bluetooth/bluetooth.h:184:9: erreur: expected ‘;’ at end of member declaration
    /usr/include/bluetooth/bluetooth.h:184:9: erreur: ‘__v’ does not name a type
    /usr/include/bluetooth/bluetooth.h:184:9: erreur: ‘typeof’ was not declared in this scope
    /usr/include/bluetooth/bluetooth.h:184:9: erreur: ‘struct bt_get_be16(const void
    )::<anonymous>’ has no member named ‘__v’

    Seems related to bluetooth, but since I don't know bluez very well, I don't know where to look at.


  • Moderators

    Have you updated QTDIR and PATH before starting the build? It seems that your search paths are polluted, or bluetooth.h - maybe - bluetooth.h is not ready for C++11, or something entirely different is happening :P.



  • This issue happened to me quite recently actually. (< 2 weeks) my bluetooth.h did not had any problems before ...



  • Seems to be ok with latest updates



  • At the compilation under Windows I have:
    Creating qmake...
    g++ -c -oproject.o -O -IC:\Users\user\Desktop\qt5-src\qtbase/qmake -IC:\Users\us
    er\Desktop\qt5-src\qtbase/qmake/generators -IC:\Users\user\Desktop\qt5-src\qtbas
    e/qmake/generators/unix -IC:\Users\user\Desktop\qt5-src\qtbase/qmake/generators/
    win32 -IC:\Users\user\Desktop\qt5-src\qtbase/qmake/generators/mac -IC:\Users\use
    r\Desktop\qt5-src\qtbase/qmake/generators/integrity -IC:\Users\user\Desktop\qt5-
    src\qtbase/include -IC:\Users\user\Desktop\qt5-src\qtbase/include/QtCore -IC:\Us
    ers\user\Desktop\qt5-src\qtbase/include/QtCore/5.0.0 -IC:\Users\user\Desktop\qt5
    -src\qtbase/include/QtCore/5.0.0/QtCore -IC:\Users\user\Desktop\qt5-src\qtbase/s
    rc/corelib/global -IC:\Users\user\Desktop\qt5-src\qtbase/mkspecs/win32-g++ -IC:
    Users\user\Desktop\qt5-src\qtbase/tools/shared -DQT_NO_TEXTCODEC -DQT_NO_UNICODE
    TABLES -DQT_LITE_COMPONENT -DQT_NO_COMPRESS -DUNICODE -DHAVE_QCONFIG_CPP -DQT_BU
    ILD_QMAKE -DQT_NO_THREAD -DQT_NO_QOBJECT -DQT_NO_GEOM_VARIANT -DQT_NO_DATASTREAM
    -DQT_BOOTSTRAPPED -DQMAKE_OPENSOURCE_EDITION project.cpp
    g++: CreateProcess: No such file or directory
    mingw32-make: *** [project.o] Error 1
    del /f project.o main.o makefile.o unixmake.o unixmake2.o mingw_make.o option.o
    winmakefile.o projectgenerator.o property.o meta.o makefiledeps.o metamakefile.o
    xmloutput.o pbuilder_pbx.o borland_bmake.o msvc_nmake.o msvc_vcproj.o msvc_vcxp
    roj.o msvc_objectmodel.o msbuild_objectmodel.o registry.o gbuild.o cesdkhandler.
    o qbitarray.o qbuffer.o qarraydata.o qbytearray.o qcryptographichash.o qvsnprint
    f.o qbytearraymatcher.o qconfig.o qdatetime.o qdir.o qdiriterator.o qfiledevice.
    o qfile.o qtemporaryfile.o qfileinfo.o qabstractfileengine.o qfilesystementry.o
    qfilesystemengine.o qfilesystemengine_win.o qfilesystemiterator_win.o qfsfileeng
    ine.o qfsfileengine_iterator.o qfsfileengine_win.o qglobal.o qhash.o qiodevice.o
    qlibraryinfo.o qlist.o qlinkedlist.o qlocale.o qlocale_tools.o qlocale_win.o qm
    alloc.o qmap.o qregexp.o qtextcodec.o qutfcodec.o qstring.o qstringlist.o qstrin
    gbuilder.o qsystemerror.o qsystemlibrary.o qtextstream.o quuid.o qvector.o qsett
    ings.o qsettings_win.o qvariant.o qmetatype.o qxmlstream.o qxmlutils.o qnumeric.
    o qlogging.o
    Could Not Find C:\Users\user\Desktop\qt5-src\qtbase\qmake\project.o
    g++ -c -oproject.o -O -IC:\Users\user\Desktop\qt5-src\qtbase/qmake -IC:\Users\us
    er\Desktop\qt5-src\qtbase/qmake/generators -IC:\Users\user\Desktop\qt5-src\qtbas
    e/qmake/generators/unix -IC:\Users\user\Desktop\qt5-src\qtbase/qmake/generators/
    win32 -IC:\Users\user\Desktop\qt5-src\qtbase/qmake/generators/mac -IC:\Users\use
    r\Desktop\qt5-src\qtbase/qmake/generators/integrity -IC:\Users\user\Desktop\qt5-
    src\qtbase/include -IC:\Users\user\Desktop\qt5-src\qtbase/include/QtCore -IC:\Us
    ers\user\Desktop\qt5-src\qtbase/include/QtCore/5.0.0 -IC:\Users\user\Desktop\qt5
    -src\qtbase/include/QtCore/5.0.0/QtCore -IC:\Users\user\Desktop\qt5-src\qtbase/s
    rc/corelib/global -IC:\Users\user\Desktop\qt5-src\qtbase/mkspecs/win32-g++ -IC:
    Users\user\Desktop\qt5-src\qtbase/tools/shared -DQT_NO_TEXTCODEC -DQT_NO_UNICODE
    TABLES -DQT_LITE_COMPONENT -DQT_NO_COMPRESS -DUNICODE -DHAVE_QCONFIG_CPP -DQT_BU
    ILD_QMAKE -DQT_NO_THREAD -DQT_NO_QOBJECT -DQT_NO_GEOM_VARIANT -DQT_NO_DATASTREAM
    -DQT_BOOTSTRAPPED -DQMAKE_OPENSOURCE_EDITION project.cpp
    g++: CreateProcess: No such file or directory
    mingw32-make: *** [project.o] Error 1
    Building qmake failed, return code 2

    *** qtbase/configure exited with non-zero status.

    but if I cd qtbase/qmake/;mingw32-make all it work.



  • On MAC I encountered a problem: Under the last version of XCode you have to download the "command lines tools" seperatly from the xcode settings in the downloads pane.



  • I was getting "The Remote End Hung up Unexpectedly" when running "perl init-repository". I found that if I used the "-http" option at the end of that line, the failures stopped. It seems that the "git" protocol is a bit flaky. Making http the default in the "init-repository" script would make the process a bit more robust.


  • Moderators

    You can also rerun the script with "-f". Doesn't fix git protocol, but often it works on second try.



  • Yeah, unfortunately for me, re-runnng w/git kept failing at different points.



  • Hi,
    I'm new to command line compiling and Git.

    Thanks to the excellent "guide":http://qt-project.org/wiki/Building_Qt_5_from_Git I was able to build Qt from source. Now, with the latest beta 2 release, I'd like to update Qt.

    My question is simple:

    Do I need to run configure after:

    git pull
    git submodule update --recursive

    Or can I just run make again without doing that?

    A suggestion would be to update the "Getting Updates" section to include this answer as maybe others would wonder if they need to do that too.

    Thanks,
    Brett


  • Moderators

    Tricky. Depends on what has changed in the source code, really. If you have a solid CPU and a bit of time on your hands, you can definitely try just running make, and then if it fails, you should do a proper clean (git clean -dxf, check the link you provided for a submodule declaration), configure and make.



  • Thanks for your post. I modified the wiki page updates section with a note that clean and configure may need to be re-run.



  • I'm building on windows 7 x64 with msvc2010 sp1 nmake.

    For some reason the naming convention is different then the beta release and incompatible with the vs-addin..

    All my lib files, dll files etc are named Qt5[lib].dll/lib instead of Qt[lib]5.dll/lib

    My config: configure -developer-build -opensource -nomake examples -nomake tests





  • Hi,

    First I have setup qt5 (both with the linux birnary file and by compiling it) on an Ubuntu 12.04 (and 11.10) KVM virtual machine. But I can't launch any graphical qt program. I have issue with QPainter: that kind of mistakes:

    @cedric@cedric-virtual-machine:~/Qt5.0.0beta2/5.0.0-beta2/gcc/bin$ ./assistant
    QWidget::paintEngine: Should no longer be called
    QPainter::begin: Paint device returned engine == 0, type: 1
    QWidget::paintEngine: Should no longer be called
    QPainter::begin: Paint device returned engine == 0, type: 1
    QPainter::font: Painter not active
    QPainter::pen: Painter not active
    ...@

    So I tried on a windows 32 bits virtual machine. First I installed it with the binary but I couldn't find our the right microsoft compiler so it could work. So I tryed to compile it with mingw32-make. It worked with the following config:
    @configure -platform win32-g++ -opengl desktop@
    Yeah I couldn't find the right version of direct X sdk so I had some issue and choose to use the opengl option.

    This version doesn't work with qt creator. I don't know if it is suppoed to? I have an issue with "ABI detection failed. Make sur to use a matching compiler when building. No qml viewer." But I can launch the program named qmlviewer.exe. Also I can compile the following application with qmake.

    pro file:
    @######################################################################

    Automatically generated by qmake (3.0) sam. 15. déc. 15:49:19 2012

    ######################################################################

    QT += widgets
    TEMPLATE = app
    TARGET = test03withoutCreator
    DEPENDPATH += .
    INCLUDEPATH += .

    Input

    SOURCES += main.cpp
    @

    main.cpp
    @#include <QGuiApplication>
    #include <QPushButton>

    Q_DECL_EXPORT int main(int argc, char *argv[]){
    QGuiApplication app(argc, argv);

    QPushButton button("work");
    button.show();
    
    return app.exec(&#41;;
    

    }@

    but then, I have no idea how to launch it. I did:
    @qmake
    mingw32-make release@
    Then I put the binary file in qtbase/bin, but I when I launch the application, I get the following message:
    "This application has requested the runtime to terminate it in an unusual way."
    But the exemples and demos can be launch without any dll in their direcotry. I don't get how that is possible.

    Someone know what I should do so I can compile and launch application?

    Sincerly,

    Cédric



  • I'm having trouble building the final release on Windows 7 x64 with both VS2008 and VS2012. I have ActivePerl and Python 2.7 installed and in the path, and in both cases when I run "configure" I get this error:
    @
    'T:\home\Qt\5.0.0\qtbase\configure.exe' is not recognized as an internal or external command, operable program or batch file.
    *** qtbase/configure exited with non-zero status.@

    Any ideas?


  • Moderators

    -You should be running configure.exe on windows, not the bash script.-

    Add a file named ".gitignore" to the root folder or comment out line 45 in configure.bat.



  • After several failed attempts at building, here's how I finally managed to get QT5 to build with Nuwen.net's MinGW 9.4, on Windows 7 64 bit SP1 without webkit.

    I already had Nuwen's mingw 9.4 installed (9.5 is now available), this can be obtained from http://www.nuwen.net/mingw.html

    This needs to be extracted to c:\mingw or similar, and c:\mingw\bin will need to be in the PATH env variable.

    Then I copied c:\mingw\bin\make.exe to c:\mingw\bin\mingw32-make.exe

    I then downloaded and installed the following:

    http://www.python.org/ftp/python/3.3.0/python-3.3.0.amd64.msi
    http://files.rubyforge.vm.bytemark.co.uk/rubyinstaller/rubyinstaller-1.9.3-p362.exe
    http://downloads.activestate.com/ActivePerl/releases/5.16.1.1601/ActivePerl-5.16.1.1601-MSWin32-x64-296175.msi
    https://msysgit.googlecode.com/files/Git-1.8.0-preview20121022.exe

    I used the installers to set the path for python, ruby and perl.

    I downloaded QT5 (27th Dec 2012):

    git clone git://gitorious.org/qt/qt5.git qt5
    cd qt5
    perl init-repository

    Configured QT5:

    configure -developer-build -opensource -nomake examples -nomake tests -qt-pcre -qt-libjpeg -opengl desktop

    • Configure informed me that webkit would not be built due to a missing dependency, so no additional parameters were required to disable this.
    • I have an ATi Radeon graphics driver with builtin OpenGL support
    • By default configure sets pcre to 'system' at one point I downloaded and built the latest version of pcre, including the pcre16 library, I placed this into my system path, but ld was still unable to locate the library and there was no means of passing the -L parameter to ld from what I can tell, build would fail with 'unable to locate pcre16', once you specify -qt-pcre as per the above, the build will use the embedded pcre library and magically succeed.
    • Again, for me, build would fail without specifying -qt-libjpeg

    I then simply ran 'make'

    Good luck!



  • What is the url for the development branch for qt5?
    git://gitorious.org/qt/qt5.git does not have modifications since December, and git://gitorious.org/qt/qt.git still contains 4.8

    thanks


  • Moderators

    Every module has a separate git repository, with the exception of QtCore, QtNetwork, QtGui, they are in qtbase.


  • Moderators

    [quote author="sierdzio" date="1357749703"]Every module has a separate git repository, with the exception of QtCore, QtNetwork, QtGui, they are in qtbase.[/quote]Actually,

    qtbase.git contains:

    • Qt Concurrent
    • Qt Core
    • Qt D-Bus
    • Qt GUI
    • Qt Network
    • Qt OpenGL
    • Qt Print Support
    • Qt SQL
    • Qt Test
    • Qt Widgets
    • Qt XML

    qtdeclarative.git contains:

    • Qt QML
    • Qt Quick

  • Moderators

    Ah, I've been punished for my laziness, thank you for that ;)



  • Hi, I've succeed with compiling QT5 for arm (raspberry pi) what is not working for me is localized keyboard input in eglfs. When i use loadkeys de.kmap and than start an application. The keyboard is again Generic (US). But in console localized keyboard works. Did I miss something in compile or programming time?


  • Moderators

    Hi yeckel,

    I don't have any experience with the Raspberry Pi, but I recommend posting your question in the "Qt Project Mobile and Embedded subforum":http://qt-project.org/forums/viewforum/11/ or the "Raspberry Pi forum":http://www.raspberrypi.org/phpBB3/



  • Hello,

    I am trying to compile qt5.0.1 in 32bits mode using msvc2012 on a 64bits machine. I have succesfully build the exactly same sources in 64bits mode, many times.

    So I opened a "vs2012-x86 native tools command prompt" and just did exactly the same steps as i did to compile the 64bits version.

    After a long time, in the nmake phase, I encountered the following error:

    [code]Microsoft (R) Program Maintenance Utility Version 11.00.50727.1
    Copyright (C) Microsoft Corporation. All rights reserved.

        cd windows\ && ( if not exist Makefile C:\qt5\qt5_32\qtbase\bin\qmake C:
    

    \qt5\qt5_32\qtbase\src\plugins\platforms\windows\windows.pro -o Makefile ) && "C
    :\Program Files (x86)\Microsoft Visual Studio 11.0\VC\BIN\nmake.exe" -f Makefile

    Microsoft (R) Program Maintenance Utility Version 11.00.50727.1
    Copyright (C) Microsoft Corporation. All rights reserved.

        "C:\Program Files (x86)\Microsoft Visual Studio 11.0\VC\BIN\nmake.exe" -
    

    f Makefile.Debug all

    Microsoft (R) Program Maintenance Utility Version 11.00.50727.1
    Copyright (C) Microsoft Corporation. All rights reserved.

        echo 2 /* CREATEPROCESS_MANIFEST_RESOURCE_ID */ 24 /* RT_MANIFEST */ "..
    

    \..\..\..\plugins\platforms\qwindowsd.dll.embed.manifest">........\plug
    ins\platforms\qwindowsd.dll_manifest.rc
    if not exist ........\plugins\platforms\qwindowsd.dll del ........
    \plugins\platforms\qwindowsd.dll.embed.manifest>NUL 2>&1
    if exist ........\plugins\platforms\qwindowsd.dll.embed.manifest copy
    /Y ........\plugins\platforms\qwindowsd.dll.embed.manifest ........\plugi
    ns\platforms\qwindowsd.dll_manifest.bak
    link /NOLOGO /DYNAMICBASE /NXCOMPAT /DEBUG /DLL /MANIFEST /MANIFESTFILE:
    ........\plugins\platforms\qwindowsd.dll.embed.manifest /OUT:........\plug
    ins\platforms\qwindowsd.dll @C:\Users\Philippe\AppData\Local\Temp\nm8E9D.tmp
    Creating library ........\plugins\platforms\qwindowsd.lib and object ....
    ....\plugins\platforms\qwindowsd.exp
    dlldata.obj : error LNK2001: unresolved external symbol _Accessible2_ProxyFileIn
    fo
    dlldata.obj : error LNK2001: unresolved external symbol _AccessibleAction_ProxyF
    ileInfo
    dlldata.obj : error LNK2001: unresolved external symbol _AccessibleApplication_P
    roxyFileInfo
    dlldata.obj : error LNK2001: unresolved external symbol _AccessibleComponent_Pro
    xyFileInfo
    dlldata.obj : error LNK2001: unresolved external symbol AccessibleEditableText
    ProxyFileInfo
    dlldata.obj : error LNK2001: unresolved external symbol _AccessibleHyperlink_Pro
    xyFileInfo
    dlldata.obj : error LNK2001: unresolved external symbol _AccessibleHypertext_Pro
    xyFileInfo
    dlldata.obj : error LNK2001: unresolved external symbol _AccessibleImage_ProxyFi
    leInfo
    dlldata.obj : error LNK2001: unresolved external symbol _AccessibleRelation_Prox
    yFileInfo
    dlldata.obj : error LNK2001: unresolved external symbol _AccessibleTable_ProxyFi
    leInfo
    dlldata.obj : error LNK2001: unresolved external symbol _AccessibleTable2_ProxyF
    ileInfo
    dlldata.obj : error LNK2001: unresolved external symbol _AccessibleTableCell_Pro
    xyFileInfo
    dlldata.obj : error LNK2001: unresolved external symbol _AccessibleText_ProxyFil
    eInfo
    dlldata.obj : error LNK2001: unresolved external symbol _AccessibleValue_ProxyFi
    leInfo
    ........\plugins\platforms\qwindowsd.dll : fatal error LNK1120: 14 unresolved
    externals
    NMAKE : fatal error U1077: '"C:\Program Files (x86)\Microsoft Visual Studio 11.0
    \VC\BIN\link.EXE"' : return code '0x460'
    Stop.
    NMAKE : fatal error U1077: '"C:\Program Files (x86)\Microsoft Visual Studio 11.0
    \VC\BIN\nmake.exe"' : return code '0x2'
    Stop.
    NMAKE : fatal error U1077: 'cd' : return code '0x2'
    Stop.
    NMAKE : fatal error U1077: 'cd' : return code '0x2'
    Stop.
    NMAKE : fatal error U1077: 'cd' : return code '0x2'
    Stop.
    NMAKE : fatal error U1077: 'cd' : return code '0x2'
    Stop.
    NMAKE : fatal error U1077: 'cd' : return code '0x2'
    Stop.[/code]

    Any idea what is wrong with my setup?



  • I am trying to build qt5 on windows. However, I am not even able retrieve the soure code successfully. The inital command "git clone git://gitorious.org/qt/qt5.git qt5" completed successfully. But the next command "perl init-repository" failed with the following error information:

    • git submodule init
      0 [main] us 0 init_cheap: VirtualAlloc pointer is null, Win32 error 487
      AllocationBase 0x0, BaseAddress 0x68560000, RegionSize 0x170000, State 0x10000
      c:\program files (x86)\git\bin\sh.exe: *** Couldn't reserve space for cygwin's h
      eap, Win32 error 0
      git submodule init exited with status 256 at init-repository line 268.
      Qt::InitRepository::exe('Qt::InitRepository=HASH(0x32f290)', 'git', 'sub
      module', 'init') called at init-repository line 373
      Qt::InitRepository::git_submodule_init('Qt::InitRepository=HASH(0x32f290
      )') called at init-repository line 569
      Qt::InitRepository::run('Qt::InitRepository=HASH(0x32f290)') called at i
      nit-repository line 590

    I am using msysgit (Git for Windows) 1.8.1.2, Active Perl 5.16.3 and Python 3.3.0.


  • Moderators

    Run perl from cmd.exe, not Bash terminal.



  • I did run the command "perl init-repository" from cmd.exe directly.
    [quote author="sierdzio" date="1364192137"]Run perl from cmd.exe, not Bash terminal.[/quote]



  • I'm trying to build source from the for new bug fix which critical for me.

    I'm getting following linking error:

    @ link /NOLOGO /DYNAMICBASE /NXCOMPAT /BASE:0x67000000 /DEBUG /DLL /VERSIO
    N:5.02 /MANIFEST /MANIFESTFILE:....\lib\Qt5Cored.lib.embed.manifest /OUT:....
    lib\Qt5Cored.lib @C:\Users\dasun\AppData\Local\Temp\nm9C85.tmp
    Creating library ....\lib\Qt5Cored.lib and object ....\lib\Qt5Cored.exp
    LINK : fatal error LNK1104: cannot open file '....\lib\Qt5Cored.lib'
    NMAKE : fatal error U1077: '"C:\Program Files (x86)\Microsoft Visual Studio 10.0
    \VC\BIN\link.EXE"' : return code '0x450'
    Stop.
    NMAKE : fatal error U1077: '"C:\Program Files (x86)\Microsoft Visual Studio 10.0
    \VC\BIN\nmake.exe"' : return code '0x2'
    Stop.
    NMAKE : fatal error U1077: 'cd' : return code '0x2'
    Stop.
    NMAKE : fatal error U1077: 'cd' : return code '0x2'
    Stop.
    NMAKE : fatal error U1077: 'cd' : return code '0x2'
    Stop.@



  • I am building from Windows 7. I use the following configuration command:

    configure -developer-build -opensource -confirm-license -nomake examples -nomake tests -mp

    I see the following errors at the end of configuration output:

    Generating Visual Studio project files...
    Project WARNING: You should probably load(qt_build_config) first in bootstrap.pr
    o for QtBootstrap, as the latter also load()s qt_module.
    Project MESSAGE: Not doing so may lead to qt_module.prf overriding compiler/link
    er options in your .pro file.
    Project MESSAGE: Ignore this warning with CONFIG+=no_qt_module_warning if you kn
    ow what you are doing.
    Project ERROR: Project has no top-level .qmake.conf file.
    Qmake failed, return code 3

    Generating Makefiles...
    *** qtbase/configure exited with non-zero status.



  • I am getting following error
    "STL functionality check failed! Cannot build Qt with this STL library."

    when i run configure command i.e.
    ./configure -developer-build -xplatform android-g++ -android-ndk YOUR_NDK_DIR -android-sdk YOUR_SDK_DIR -nomake tests -nomake examples

    Exact dump

    • /home/ubuntu/qt5/qtbase/configure -developer-build -xplatform android-g++ -android-ndk /home/ubuntu/anshul/android-ndk-r8e -android-sdk /home/ubuntu/anshul/replicant-sdk_linux-x86 -nomake tests -nomake examples -confirm-license
      Which edition of Qt do you want to use ?

    Type 'c' if you want to use the Commercial Edition.
    Type 'o' if you want to use the Open Source Edition.

    o

    This is the Qt Open Source Edition.

    You are licensed to use this software under the terms of
    the Lesser GNU General Public License (LGPL) versions 2.1.

    You have already accepted the terms of the license.

    <srcbase> = /home/ubuntu/qt5/qtbase
    <outbase> = /home/ubuntu/qt5/qtbase
    Creating qmake...
    make: Nothing to be done for `first'.
    Running configuration tests...
    Warning: Disabling pkg-config since PKG_CONFIG_LIBDIR is not set.
    Warning: Disabling pkg-config since PKG_CONFIG_SYSROOT_DIR is not set.

    Could not determine the target architecture!
    Turn on verbose messaging (-v) to see the final report.
    STL functionality check failed! Cannot build Qt with this STL library.
    Turn on verbose messaging (-v) to /home/ubuntu/qt5/qtbase/configure to see the final report.
    *** qtbase/configure exited with non-zero status.

    and i am referring this link for building
    http://qt-project.org/wiki/Qt5ForAndroidBuilding

    Please help

    -Anshul



  • Hello,

    I am having some problems compiling Qt 5.1 in MAC OSX. I've followed all the steps from here: http://qt-project.org/wiki/Building_Qt_5_from_Git ...

    But... when I called "make -j 4", after about one hour of compilling work, I've got this error:

    @make[3]: *** No rule to make target /Users/paulopina/PlexusDynamics/qt5/qtbase/lib/libQt5QmlDevTools.a', needed by/Users/paulopina/PlexusDynamics/qt5/qtbase/bin/qmlmin'. Stop.
    make[2]: *** [sub-qmlmin-make_first] Error 2
    make[2]: *** Waiting for unfinished jobs....
    make[3]: Nothing to be done for first'. make[3]: Nothing to be done forfirst'.
    make[3]: Nothing to be done for `first'.
    make[1]: *** [sub-tools-make_first] Error 2
    make: *** [module-qtdeclarative-make_first] Error 2@

    This it the return i've got at "./configure -developer-build -opensource -nomake examples -nomake tests":

    @Creating qmake...
    make: Nothing to be done for `first'.
    Running configuration tests...
    WARNING: Unable to find file .device.vars

    Build type: macx-clang
    Architecture: x86_64, features: mmx sse sse2 sse3 ssse3
    Host architecture: x86_64, features: mmx sse sse2 sse3 ssse3

    Build .................. libs tools
    Configuration .......... qpa largefile precompile_header sse2 sse3 ssse3 sse4_1 sse4_2 avx avx2 absolute_library_soname pcre warnings_are_errors minimal-config small-config medium-config large-config full-config build_all debug_and_release no-pkg-config coreservices accessibility opengl shared qpa reduce_exports getaddrinfo ipv6ifname getifaddrs png freetype system-zlib nis cups iconv openssl rpath corewlan concurrent audio-backend v8 v8snapshot release debug qt_framework private_tests
    Debug .................. yes (combined)
    Default Link ........... debug
    Force debug info ....... no
    C++11 support .......... no
    pkg-config ............. no
    Qt D-Bus module ........ no
    Qt Concurrent code ..... yes
    Qt GUI module .......... yes
    Qt Widgets module ...... yes
    JavaScriptCore JIT ..... To be decided by JavaScriptCore
    QML debugging .......... yes
    PCH support ............ yes
    SSE2/SSE3/SSSE3......... yes/yes/yes
    SSE4.1/SSE4.2........... yes/yes/yes
    AVX/AVX2................ yes/yes
    IPv6 ifname support .... yes
    getaddrinfo support .... yes
    getifaddrs support ..... yes
    Accessibility .......... yes
    NIS support ............ yes
    CUPS support ........... yes
    Iconv support .......... yes
    Glib support ........... no
    GStreamer support ...... no
    PulseAudio support ..... no
    Large File support ..... yes
    GIF support ............ plugin
    JPEG support ........... plugin (qt)
    PNG support ............ yes (qt)
    zlib support ........... system
    Session management ..... auto
    libudev support ........ no
    Use system proxies ..... no
    OpenGL support ......... yes (Desktop OpenGL)
    OpenVG support ......... no
    XShape support ......... auto
    XVideo support ......... auto
    XSync support .......... auto
    Xinerama support ....... runtime
    Xcursor support ........ runtime
    Xfixes support ......... runtime
    Xrandr support ......... runtime
    Xi support ............. runtime
    Xi2 support ............ auto
    MIT-SHM support ........ auto
    FontConfig support ..... no
    XKB support ............ auto
    GTK theme support ...... no
    PostgreSQL support ..... plugin
    ODBC support ........... plugin
    SQLite support ......... plugin (qt)
    OpenSSL support ........ yes (run-time)
    Alsa support ........... no
    CoreWlan support ....... yes
    libICU support ......... no
    PCRE support ........... qt
    Xcb support ............ no
    Xrender support ........ no
    EGLFS support .......... no
    DirectFB support ....... no
    LinuxFB support ........ no
    KMS support ............ no@

    Any one has an idea of how can I solve this?

    Thank you!


Log in to reply