Cross compile Qt 5.5 on Windows 7 error missing <X11/Xutil.h.



  • Hello everyone,

    currently I'm trying to cross compile Qt 5.5 on Windows 7 for Raspberry 2 with Rasbian Jessie.
    I'm following this tutorial http://visualgdb.com/tutorials/raspberry/qt/embedded/ and most steps work fine but on step 17 I get an error when running make:

    J:/OpenSource/Qt/5.5.1/qt-everywhere-opensource-src-5.5.1/qtbase/src/plugins/platforms/xcb/qxcbmime.cpp:41:23: fatal error: X11/Xutil.h: No such file or directory
     #include <X11/Xutil.h>
                           ^
    compilation terminated.
    make[6]: *** [.obj/qxcbmime.obj] Error 1
    make[6]: Leaving directory `/J/OpenSource/Qt/5.5.1/qt-build/qtbase/src/plugins/platforms/xcb'
    make[5]: *** [sub-xcb_qpa_lib-pro-make_first-ordered] Error 2
    make[5]: Leaving directory `/J/OpenSource/Qt/5.5.1/qt-build/qtbase/src/plugins/platforms/xcb'
    make[4]: *** [sub-xcb-make_first] Error 2
    make[4]: Leaving directory `/J/OpenSource/Qt/5.5.1/qt-build/qtbase/src/plugins/platforms'
    make[3]: *** [sub-platforms-make_first] Error 2
    make[3]: Leaving directory `/J/OpenSource/Qt/5.5.1/qt-build/qtbase/src/plugins'
    make[2]: *** [sub-plugins-make_first] Error 2
    make[2]: Leaving directory `/J/OpenSource/Qt/5.5.1/qt-build/qtbase/src'
    make[1]: *** [sub-src-make_first] Error 2
    make[1]: Leaving directory `/J/OpenSource/Qt/5.5.1/qt-build/qtbase'
    make: *** [module-qtbase-make_first] Error 2
    

    I've tried googling without any success so far. I'm not sure where X11/Xutil.h is supposed to be. The path itself should be fine.

    As a note: I've tried compiling 5.6 before but there I failed way earlier when running make. There it failed on this part (and the other definitions in there):

    J:/OpenSource/Qt/5.6/qt-everywhere-opensource-src-5.6.0/qtbase/src/corelib/io/qfilesystemengine_win.cpp
    In file included from j:\tools\sysgcc\mingw32\include\security.h:40:0,
                     from J:/OpenSource/Qt/5.6/qt-everywhere-opensource-src-5.6.0/qtbase/src/corelib/io/qfilesystemengine_win.cpp:67:
    j:\tools\sysgcc\mingw32\include\secext.h:16:17: error: redeclaration of 'NameUnknown'
       NameUnknown = 0, 
    

    My Toolchain is pretty similar in both cases and I'm happy for help with any of the problem.
    Some more information that might be helpful:

    • I'm running Windows 7 Professional 64bit
    • The Raspberry Pi 2 is a model B+ with Raspbian Jessie installed. It was updated from Wheezy for this progress with dist-upgrade which went without errors. I only installed libxcbl-dev and resynchronized because otherwise configure woul fail with this xcb error message and OpenGL 2 ES.
    • I've used the toolchains from the linked tutorial.
    • GCC is located in /j/Tools/SysGCC/MinGW32/bin/gcc.exe
    • The architecture location is /j/Tools/SysGCC/Raspberry/bin/arm-linux-gnueabihf-gcc.exe
    • Qt source code is in J:\OpenSource\Qt\5.5.1\qt-everywhere-opensource-src-5.5.1 and with 5.6. in the path in the newer version.

    If you need any more info I'll try to provide it.
    I'm grateful for any hints! Thank you.



Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.