Forum missing logout button



  • It seems like I am staying logged in on the forums even after having logged out via account.qt.io. Is this supposed to happen? An in that case, where can I find a dedicated logout button for the forums?

    Also, I am missing a quick link somewhere to my own account. If I want to change my account forum settings etc., it seems as I have to search for my account name in the logged in users section or enter the URL to the account settings page manually.
    (Or am I missing the link to that page by any chance, because it is hidden in plain sight and I am just too blind to be able to see it?)

    EDIT: Locating one of my own posts allows accessing my account, too, of course. However, this is as cumbersome as using the forum users section.



  • This post is deleted!

  • Moderators

    Hi @NWeyand, and welcome to the Qt Dev Net!

    It seems like I am staying logged in on the forums even after having logged out via account.qt.io. Is this supposed to happen?

    Hmm... I'm not sure. @tero-kojo could provide some insight.

    Also, I am missing a quick link somewhere to my own account. If I want to change my account forum settings etc.

    In the very top-right corner of each page in the forum, there's the "Profile" button (next to the "Chats" button).

    Where can I find a dedicated logout button for the forums?

    Under the "Profile" button.


  • administrators

    Hi,
    Yes, the Profile button with your avatar is the place.

    @JKSH tero-kojo is my test alias, he rarely logs in :)



  • It seems this is the problem. If one doesn't have a profile picture yet, this is what the area looks like:
    http://postimg.org/image/ozt75lmif/

    So basically, the button is there, but it it is effectively invisible without an avatar.

    IMHO, there should either be a default avatar on account creation, a fallback image for the profile button or a boarder around the profile picture when used as a button so newly registered (or simply lazy) users can still find the button. ;)


  • administrators

    @NWeyand oh, that looks like something is wrong.

    Are you by any chance using ghostery or some other blocker?
    The avatars we use are from Gravatar (have been for quite a long time). So letting gravatar.com content into the page should fix the blank space.
    The default avatar is the common gray mystery person.



  • @tekojo indeed, I am using ghostery. And by allowing gravatar on this site, the problem is easily resolved. However as I am not the only person relying on a script/adblocker in the world, maybe you should consider making the button visible for those who are (Maybe by displaying a small black or gray dot in the center of where the image would be (as long as|if) no image from gravatar is loaded).


  • administrators

    @NWeyand we'll take a look at what to do when the next upgrade comes along. Should be in the next two months, there is a new stable version out now.
    It probably can be fixed by setting a background colour to the avatar.



  • That would be much appreciated!


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.