problemas al compilar con Qt 5.5.1



  • hola amigos tengo un problema, descargue el Qt 5.5.1, lo instale, todo bien hasta ahí, pero cuando quiero compilar o ejecutar algún programa, no me deja, me sale el siguiente error:

    12:21:24: Running steps for project lincoln...
    12:21:24: Starting: "C:\Qt\Qt5.5.1\5.5\mingw492_32\bin\qmake.exe" C:\Users\user}\Documents\Qt-Projects\lincoln\lincoln.pro -r -spec win32-g++ "CONFIG+=debug"
    12:21:25: The process "C:\Qt\Qt5.5.1\5.5\mingw492_32\bin\qmake.exe" exited normally.
    12:21:25: Starting: "C:\Qt\Qt5.5.1\Tools\mingw492_32\bin\mingw32-make.exe"
    qtcreator_ctrlc_stub: Command line failed: C:\Qt\Qt5.5.1\Tools\mingw492_32\bin\mingw32-make.exe
    12:21:25: The process "C:\Qt\Qt5.5.1\Tools\mingw492_32\bin\mingw32-make.exe" exited with code -1.
    Error while building/deploying project lincoln (kit: Desktop Qt 5.5.1 MinGW 32bit)
    When executing step "Make"
    12:21:25: Elapsed time: 00:00.

    hasta ahora no he podido saber por que sale este error, si pudieran ayudarme seria de
    gran utilidad, ya que no puedo trabajar normalmente, gracias de antemano..

    Nota: tengo un sistema operativo windows 8.1 de 64 bits, anteriormente tenia el qt 5.5, si sirve de algo...



  • Hola

    ¿Eso te ocurre con un proyecto que creaste con una versión anterior de Qt?

    Si es así prueba haciendo "Clean Proyect" y copilando después. Y si no prueba borrando a mano todos loa archivos que genera QtCreator (.o, moc_. ui_.*, etc) y luego compilando.

    Un saludo



  • hola que tal, bueno en realidad ocurre con cualquier proyecto, intente crear un proyecto con la version 5.5.1, pero tampoco funciona.



  • Hola

    @solitarywolf said:

    hola que tal, bueno en realidad ocurre con cualquier proyecto, intente crear un proyecto con la version 5.5.1, pero tampoco funciona.

    Pues entonces no se, quizás te hayas dejado algún paquete por instalar o algo así.

    Un saludo



  • hola, pues ya lo he vuelto a reinstalar un montón de veces, y aun persiste el problema, volveré a instalar la versión 5.5.0, no queda de otra, gracias



  • Hola @solitarywolf

    ¿Revisaste los "kits de compilación"? Tools->Options->Build and Run->Kits

    Si tienes algún problema con el compilador o te falta algo te aparecerá en rojo.

    Un saludo



  • bueno ya revise todo eso y esta bien, ya no se que hacer, instalare la versión anterior, la 5.5.0, esta trabajando sin problemas, gracias



  • @juanki, creo que ese el problema en mi caso, además de que no crea el Build directory, y es eso lo que me sale en rojo, la supuesta dirección de esta carpeta, qué debo hacer en caso de que de los kits de compilación no estén completos?

    Porque en la dirección que indicas, también muestra el error "Error: No compiler set in kit."



  • Hola @Mateo

    Si no tienes los kits de compilación, revisa que tengas el compilador instalado, que esté en el path la ruta a su ejecutable y que hayas instalado el paquete correcto de Qt, es decir, si usas mingw, asegúrate que instalaste la versión adecuada de Qt, y lo mismo para msvc.

    Un saludo


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.