[solved] cross-compile Qt5 for the Raspberry Pi



  • hello,
    I tried to follow RaspberryPi Beginners Guide
    and I get this compiler output
    does anyone know what is wrong?

    ............................ .obj/qelapsedtimer_unix.o: In functionqt_gettime()':
    qelapsedtimer_unix.cpp:(.text+0x34): undefined reference to clock_gettime' .obj/qelapsedtimer_unix.o: In functionQElapsedTimer::start()':
    qelapsedtimer_unix.cpp:(.text+0xa0): undefined reference to clock_gettime' .obj/qelapsedtimer_unix.o: In functionQElapsedTimer::restart()':
    qelapsedtimer_unix.cpp:(.text+0xe0): undefined reference to clock_gettime' .obj/qelapsedtimer_unix.o: In functionQElapsedTimer::nsecsElapsed() const':
    qelapsedtimer_unix.cpp:(.text+0x168): undefined reference to clock_gettime' collect2: error: ld returned 1 exit status Makefile:1289: recipe for target '../../lib/libQt5Core.so.5.5.1' failed make[2]: *** [../../lib/libQt5Core.so.5.5.1] Error 1 make[2]: Leaving directory '/home/mchl/opt/qt5/qtbase/src/corelib' Makefile:170: recipe for target 'sub-corelib-make_first' failed make[1]: *** [sub-corelib-make_first] Error 2 make[1]: Leaving directory '/home/mchl/opt/qt5/qtbase/src' Makefile:45: recipe for target 'sub-src-make_first' failed make: *** [sub-src-make_first] Error 2 mchl@debianJessie:~/opt/qt5/qtbase$
    +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

    my system VirtualBox OS: Debian 8.2 jessie Kernel: x86_64 Linux 3.16.0-4-amd64
    Thanks in advance for an answer



  • I setup a clean machine


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.