To run the executable created using Qt, without Qt creator



  • Hello

    When I try to run the executable created in Qt project release folder, getting the following error:
    The application was unable to start correctly(0xc000007b)

    Used Dependency Walker to find the needed .dll files, but still the problem persists.



  • Hi, error 0xc000007b usually occurs because there's a mix-up between 32-bit and 64-bit versions of the same DLL.
    You could try Start Profiling (hitting F7) in Dependency Walker, in the trace window you should be able to see which DLL is causing the error.



  • I tried profiling in Dependency Walker but getting the following error

    ===============================
    Starting profile on 7/31/2015 at 2:16:19 PM

    Operating System: Microsoft Windows NT/2000/XP/2003/Vista based Professional (64-bit), version 6.02.9200
    Program Executable: e:\my documents\exe\demo\DEMO_1.EXE
    Program Arguments:
    Starting Directory: E:\My Documents\exe\Demo
    Search Path: C:\Program Files (x86)\Intel\iCLS Client;C:\Program Files\Intel\iCLS Client;C:\windows\system32;C:\windows;C:\windows\System32\Wbem;C:\windows\System32\WindowsPowerShell\v1.0;C:\Program Files (x86)\Intel\OpenCL SDK\3.0\bin\x86;C:\Program Files (x86)\Intel\OpenCL SDK\3.0\bin\x64;C:\Program Files\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files\Intel\Intel(R) Management Engine Components\IPT;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\IPT;C:\ProgramData\Lenovo\ReadyApps;C:\Program Files\TortoiseSVN\bin;C:\Python27;C:\Program Files\Microsoft SQL Server\110\Tools\Binn;C:\Program Files (x86)\Microsoft SDKs\TypeScript\1.0;C:\Program Files\Microsoft SQL Server\120\Tools\Binn;C:\Program Files (x86)\Windows Kits\8.1\Windows Performance Toolkit;C:\Users\divyasubramanian\AppData\Local\Code\bin

    Options Selected:
    Simulate ShellExecute by inserting any App Paths directories into the PATH environment variable.
    Log DllMain calls for process attach and process detach messages.
    Log DllMain calls for all other messages, including thread attach and thread detach.
    Hook the process to gather more detailed dependency information.
    Log LoadLibrary function calls.
    Log GetProcAddress function calls.
    Log debug output messages.
    Automatically open and profile child processes.

    Started "DEMO_1.EXE" (process 0x134C) at address 0x000007F6A76B0000. Error hooking module, will try again later.
    Loaded "NTDLL.DLL" at address 0x000007FC50000000. Successfully hooked module.
    Loaded "KERNEL32.DLL" at address 0x000007FC4FE70000. Successfully hooked module.
    Loaded "KERNELBASE.DLL" at address 0x000007FC4D010000. Successfully hooked module.
    DllMain(0x000007FC4D010000, DLL_PROCESS_ATTACH, 0x0000000000000000) in "KERNELBASE.DLL" called.
    DllMain(0x000007FC4D010000, DLL_PROCESS_ATTACH, 0x0000000000000000) in "KERNELBASE.DLL" returned 1 (0x1).
    DllMain(0x000007FC4FE70000, DLL_PROCESS_ATTACH, 0x0000000000000000) in "KERNEL32.DLL" called.
    DllMain(0x000007FC4FE70000, DLL_PROCESS_ATTACH, 0x0000000000000000) in "KERNEL32.DLL" returned 1 (0x1).
    Injected "DEPENDS.DLL" at address 0x0000000052FE0000.
    DllMain(0x0000000052FE0000, DLL_PROCESS_ATTACH, 0x0000000000000000) in "DEPENDS.DLL" called.
    DllMain(0x0000000052FE0000, DLL_PROCESS_ATTACH, 0x0000000000000000) in "DEPENDS.DLL" returned 1 (0x1).
    Loaded "SYSFER.DLL" at address 0x0000000054D60000. Successfully hooked module.
    Loaded "QT5QUICK.DLL" at address 0x000000006E5C0000. Successfully hooked module.
    Loaded "QT5QUICK.DLL" at address 0x00000000004C0000. Successfully hooked module.
    Unloaded "QT5QUICK.DLL" at address 0x00000000004C0000.
    Unloaded "QT5QUICK.DLL" at address 0x000000006E5C0000.
    Exited "DEMO_1.EXE" (process 0x134C) with code -1073741701 (0xC000007B).

    Please let me know what can be done.



  • @hskoglund
    When tried to open the executable using Dependency Walker, getting the following error

    ======================
    Error: At least one module has an unresolved import due to a missing export function in an implicitly dependent module.
    Error: Modules with different CPU types were found.

    ================


  • Moderators

    @Divya-Subramanian said:

    Error: Modules with different CPU types were found.

    Like @hskoglund said, your problem is caused by mixing 32-bit and 64-bit files.

    Are you trying to build a 32-bit or 64-bit app?



  • Hi Divya,

    I would try to run it from the command line with an empty PATH variable like the following:
    SET PATH=
    DEMO_1.EXE



  • You have to place the respective libraries and plugins in corresponding place where the executable is placed. And the libraries and plugins must be refering to executables.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.