Qt Creator - Plugin Loader errors



  • !http://i53.tinypic.com/345bec6.jpg(warning)!

    How can I correct this errores appearing to me since I upgraded to Qt 2.2 RC?


  • Moderators

    Make sure you have only plugins matching the version of Qt Creator you are using. The message looks like you had installed a newer Creator with new plugins and then went back to one that does not have those.



  • Soft solution: go to <qtcreatorpath>/lib/qtcreator/plugins/Nokia/ open .pluginspec files and manually correct versions of dependencies.



  • Actually I installed the Qt SDK 1.0 and then Qt Creator 2.1 over it. Then I upgraded to Qt Creator 2.2 RC (here the problem started) and today I installed Qt SDK 1.1!



  • Are you installing different versions of QtCreator in one place (for example in Windows: "C:\QtSDK\QtCreator") ? If so, why don't you try different place?

    In the moment I have several versions...trying some snapshots, 2.2RC, maybe 2.1 too ... and they don't interfere with one another.



  • Yes as I explained before I upgraded from the stable version to the RC, installing one version over the other. Same for the SDK, but today was released the stable version of 1.1 and now I'm running it.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.