Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Error: Qt to be configured with -opengl



  • Hello,

    i just tried running the samples codes from the qt (clocks )it works fine (cross-compiled)
    but examples code from the /Examples/Qt-5.3/opengl/framebufferobject2 is giving me error as follows

    18:18:45: Running steps for project framebufferobject2...
    18:18:45: Starting: "/opt/poky/1.6.1/sysroots/i686-pokysdk-linux/usr/bin/qt5/qmake" /home/minda/Qt5.3.1/Examples/Qt-5.3/opengl/framebufferobject2/framebufferobject2.pro -r -spec linux-arm-gnueabi-g++ CONFIG+=debug
    Project ERROR: This example requires Qt to be configured with -opengl desktop
    18:18:45: The process "/opt/poky/1.6.1/sysroots/i686-pokysdk-linux/usr/bin/qt5/qmake" exited with code 3.
    Error while building/deploying project framebufferobject2 (kit: wandboard)
    When executing step 'qmake'
    18:18:45: Elapsed time: 00:00.

    Can anyone please help.

    Thanks
    Nilesh kokane


  • Moderators

    You have most probably compiled Qt with -opengl es option enabled. You are getting this error, because a higher version of OpenGL is required for them (at least that is how I understand the message). Please recompile Qt using -opengl desktop option, if possilble.



  • Hi ,

    Thanks for your valuable reply first of all.

    I've followed http://wiki.wandboard.org/index.php/Building_Qt5_using_yocto_on_Wandboard to set up the Qt.

    Please recompile Qt using -opengl desktop option, if possilble
    from where can i select -opengl desktop option

    sorry for silly question .I'm novice to Qt

    Thanks
    Nilesh Kokane


  • Moderators

    You have not asked a question, so no need to be sorry ;-)

    It is very possible that the board you have does not support desktop OpenGL, only ES version. In such case, you simply need to accept it and move on.



  • Hello,

    Thanks for your valuable reply .

    so you mean to say the specifics of wandboard doesnt allow the open gl (sample code framebuffer2) can't be run at all.

    if I wanna make it run for wandboard. what do I need to change in the setup so that the framebuffer2 code can run

    Thanks
    Nilesh Kokane


Log in to reply