Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

New Qt for Embedded Linux Series started



  • I think the framebuffer has nothing to do with the x-server! Can you start the "X -verbose" manual without startx? Or show the X.log file.



  • bq. If you plan to start with tests on this, please tell me, so I can save at least the time I already spent for silly problems. But blocking. As you know, I imagine, all problems on embedded platforms are silly when you discover why the occurs.

    That sounds good. Next week I'm on holiday but when I'm back I will start to try.



  • bq. I took a look to your Pengutronix development platform and as I read it seems interesting because very open.

    Yes that was important for us. In our first linux device we had used the timesys from timetorm. This tool is based on eclipse and very expensiv. And worst was that after the license is expired you can not use the tool anymore. You can not do anything in the old project :-(



  • I have no X command. Probably I was not clear, because this is the first time I use on an embedded platform a screen display. I compiled the kernel & UImage with the Fb display driver. This is surely correct because I checked with the hardware developer. Then I setup the configuration with X11 that is a tiny x server and twm as window viewer. Thus, what I have in the filesystem as commands startx that is the script the launch Kfbdev (the x-server if I have understood) trying with screen :0 (defined in DISPLAY as an environment variable)
    Then the next command is twm -display:0

    I always obtain the same message : unable to open display ":0"

    Following my investigations, the thing that I don't know is where I can search for the configuration file similar to the definitions I find with the common X11 environment in non-embedded linux.

    This is my need only to have a complete check of the platform (hardware + software) and next step is to start with Qt



  • As long as I have used and seen x11, there was always an x-server, x-client and an window manager like twm. Kfbdev I don't know. Maybe I have to take a look at this. But why you don't use the qws? This is what I'm using on our device. Anyway, try to set the "DISPLAY=127.0.0.1:0.0", somtimes "DISPLAY=:0" is not enough.



  • Do you mean TinyX. Have you seen "this":http://www.xfree86.org/current/TinyX.1.html page?



  • Alicemirror: if you have a working framebuffer device then you can skip X entirely by using Qt Embedded as this draws directly to the framebuffer and provides its own window manager (QWS).

    Check that your user has sufficient permissions to open the /dev/fb0 device too.



  • @Scylla: Yes I have seen TynyX. The X server I use is part of his family, not exactly this but the principle is the same.
    Thus I tried too your suggestion exporting DISPLAY including the IP address. Before I have already tried before the lan ip address of the board and the result is the same. What I think is that maybe a stupid think I don't know or forget, because these settings in ltib are almost standard. You suggest another windows manager; I am using twm just because this is the window manage recognized by ltib for this kind of platform. To be honest, I have no idea at this moment what can be the missing component or file that create this strange behavior. I am trying to investigate on configuration file missing (is it possible?)

    @ZapB: As I wrote above, I agree totally with you: my final target is what you suggest. This X test is only a parallel check. Initially I thought that the simple way was to check the "official" ltib LPC3250 X server mode then create the version with Qt embedded. At the actual date, seeing the problem I am experiencing, including the very small support (near to zero) probably the best choice is to abandon the X version focusing my attention (thanks to the your support and of the other forum members) to Qt embedded saving time and obtaining best results. Do you agree ?

    P.S. I am working with the board connecting via ssh as root (tried also as user + sudo too). As embedded platform I don't set special users permission list but simply for now I am using an ssh access (with password) and the root user is doing all the job.



  • It's certainly worth giving Qt for Embedded Linux a try. Just build it and copy across the libs and some examples to see if it works for you.

    I'll try to write some of the other articles in the Qt Embedded series in the next few days but I may be offline for sometime this week.



  • ZapB, it's not only worh, it's my definitive choice. And as project reference, I'm the only that decide what to do. So, the actual balance tell me that this is the right choice. I hope to have some good news next week when you are online again :)

    Thank you very much for the hints, I appreciate a lot.



  • Try the framebuffer test program (examples/qws/framebuffer). If this works, don't waste your time with x11. This was exactly my first test on our arm system.



  • Same here. Followed by some of the examples since from memory the framebuffer test app does not require the qws stuff which in turn requires the fonts ot be found which was another "gotcha" I fell for. ;-)



  • And if your framebuffer device is not /dev/fb0 just set the right device as option for the framebuffer test program.



  • Hi :) Sorry for the delay in my answer. Today is a hard day of setup and computer organization...

    WELL ! Convincted!

    I proceed with Qt4embedded. News later.



  • That was a good choice ;)



  • I am sure. But the real good choice I think is to abandon X server ... Now I should download Qt for embedded then check if it is best to develop under that (new for me) toolchain that you are always using - Scylla - or ltib.

    @Scilla: if you have some time for me I'll like to discuss advantages and problems to choice your toolchain or ltib (or OpenWrt). Next days I can write some specific pages on these on the wiki as a compendium to what is writing ZapB



  • Good luck! It can be frustrating at first as you feel your way but it's worth it in the end. I look forward to reading your write up.



  • Ok, no problem but today it's birthday of my wife, so no time today. Let's try tomorrow. If you want I can provide my toolchain.



  • Happy birthday to your wife!!! She is pisces sign?

    It's good, if you email me I can provide you a decent ftp (home nas for personal use) access to share what can't be fit in a hosted projects.forum.nokia.com while for the other stuff I create a nokia project. You can be of the team developer crew :)



  • So, now I'm back.

    bq. She is pisces sign?

    Yes, indeed she is!

    bq. It’s good, if you email me I can provide you a decent ftp (home nas for personal use) access to share what can’t be fit in a hosted projects.forum.nokia.com while for the other stuff I create a nokia project. You can be of the team developer crew :)

    Ok, this can we do. Which toolchain do you need, x86 or arm? I've got both, with integreated Qt. That means, you can use that toolchain direct without anything else. The x86 version is build with Qt 4.7.0, will be updated propably soon. The arm version is build with Qt 4.7.2, so it's brand new.

    And on monday I'm back at work. So let me know, if you are interested in!


Log in to reply