Qt giving the ld error



  • Hi ,

    Based on the url http://wiki.wandboard.org/index.php/Building_Qt5_using_yocto_on_Wandboard

    bitbake core-image-minimal and bitbake meta-toolchain-qt5

    Both gave me success.

    But after setting the qt creator and running the example clocks code its giving me the ld errors as follows

    09:41:15: Running steps for project clocks...

    09:41:15: Configuration unchanged, skipping qmake step.

    09:41:15: Starting: "/usr/bin/make"

    arm-linux-gnueabi-g++ -o clocks main.o qrc_clocks.o -L/opt/poky/1.6.1/sysroots/cortexa9hf-vfp-neon-poky-linux-gnueabi/usr/lib -lQt5Quick -lQt5Qml -lQt5Network -lQt5Gui -lQt5Core -lGLESv2 -lpthread

    /usr/lib/gcc-cross/arm-linux-gnueabi/4.7/../../../../arm-linux-gnueabi/bin/ld: cannot find /lib/libpthread.so.0 inside

    /usr/lib/gcc-cross/arm-linux-gnueabi/4.7/../../../../arm-linux-gnueabi/bin/ld: cannot find /usr/lib/libpthread_nonshared.a inside

    collect2: error: ld returned 1 exit status

    make: *** [clocks] Error 1

    09:41:15: The process "/usr/bin/make" exited with code 2.

    Error while building/deploying project clocks (kit: wandboard)

    When executing step 'Make'

    09:41:15: Elapsed time: 00:00.

    I've assuared that the set up in the Configure Qt creators OK , but its still giving the error.

    can you suggest me for that.



  • Hi

    I have a final setup of Qt-creator as follows.I ran the script in the /opt/poky/1.6.1/ and opened the qt-creator from the concole. with this settings as below i'm trying to cross-compile the sample clock code

    1. General http://picpaste.com/1-gAmJsS3o.png
    2. Kits http://picpaste.com/2-Y3kFvHIG.png
    3. Qt version http://picpaste.com/3-lwZngysy.png
      4 compiler http://picpaste.com/4-M4y6gJYb.png
    4. Debugger http://picpaste.com/5-DQhrxi6t.png
    5. CMake http://picpaste.com/6-l3FhICDq.png
    6. Build Settings http://picpaste.com/7-4myooBgL.png

    With the settings ,clock code is giving me error[8].

    1. http://picpaste.com/8-kGmTWy3P.png

    14:32:34: Running steps for project clocks...

    14:32:34: Could not start process "/opt/poky/1.6.1/sysroots/cortexa9hf-vfp-neon-poky-linux-gnueabi/usr/bin/make" clean

    Error while building/deploying project clocks (kit: wandboard)

    When executing step 'Make'

    14:32:34: Elapsed time: 00:00.

    Please if you can assist.

    Thanks


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.