[Solved] More Qt Dll Issues. Cannot find windows plugin in debug mode.



  • A while ago I posted a discussion on why Qt doesn't implement a way to copy the proper dll files to the build folder. I now understand some of the issues involved now that I have multiple versions of qt installed. However, I still maintain that this could be done for the default configuration.

    Regardless,, I am really sick of this shortcoming. I have now run into a problem where I have copied all the necessary files and I cannot even start my application in debug mode. That means I wasn't able to view the list of files I need to copy. Even so, I went one by one through all the the files I needed by restarting my application for each dll I needed to copy.

    Now it is telling me that it cannot locate the windows plugin. YES. I have copied that file. I have tried putting it in the application directory, a subdirectory called platforms, and a subdirectory called plugins\platforms. None of these have worked.

    FYI I am using the Addin for VS 2012.



  • Hi, guessing but maybe you copied qwindows.dll, but in debug mode, try instead copying qwindowsd.dll to platforms.
    (Also dlls it depends on, like libEGLd.dll...)



  • i already copied both plus the pdb.



  • Hmmmm, you mean qwindowsd.dll to platforns, and libEGLd.dll, libGLESv2d.dll, MSVCR110D.DLL, MSVCP110D.DLL etc. together with your .exe file?



  • That worked. Thanks. (I was missing one of the lib files since it was reported as missing).


  • Moderators

    Here's a reasonably quick and almost-foolproof way to identify the DLLs you need: http://qt-project.org/wiki/Deploy_an_Application_on_Windows

    Also, did you try the windeployqt tool?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.