[RESOLVIDO]Erro configurando aplicativo em Qt 5.2.1



  • Colegas do fórum, migrei da Qt 4.8.3 para Qt 5.2.1, utilizo Debian 7.0 Wheezy ,notei que esta versão aparentemente não precisa ser "compilada", como eu fazia antes, ou estou enganado?
    Utilizo o Cmake em minhas aplicações e ao tentar configurar/compilar um projeto obtive o seguinte erro:
    /home/rodolfo/Sistemas_Kdevelop/vendas/vendas/build> /usr/bin/cmake -DCMAKE_INSTALL_PREFIX=/usr/bin -DCMAKE_BUILD_TYPE=Debug /home/rodolfo/Sistemas_Kdevelop/vendas/vendas/
    CMake Warning at /usr/share/cmake-2.8/Modules/FindQt4.cmake:604 (MESSAGE):
    /home/rodolfo/Qt/5.2.1/gcc_64/bin/qmake reported QT_INSTALL_LIBS as
    "/home/rodolfo/Qt/5.2.1/gcc_64/lib" but QtCore could not be found there.
    Qt is NOT installed correctly for the target build environment.
    Call Stack (most recent call first):
    CMakeLists.txt:3 (find_package)

    CMake Error at /usr/share/cmake-2.8/Modules/FindQt4.cmake:608 (MESSAGE):
    Could NOT find QtCore. Check
    /home/rodolfo/Sistemas_Kdevelop/vendas/vendas/build/CMakeFiles/CMakeError.log
    for more details.
    Call Stack (most recent call first):
    CMakeLists.txt:3 (find_package)

    -- Configuring incomplete, errors occurred!
    Já configurei o /etc/profile com o caminho da instalação da QT:
    if [ "id -u" -eq 0 ]; then
    PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/home/rodolfo/Qt/5.2.1/:/home/rodolfo/Qt/5.2.1/gcc_64/bin/"
    else
    PATH="/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games:/home/rodolfo/Qt/5.2.1/:/home/rodolfo/Qt/5.2.1/gcc_64/bin/"
    fi

    Vi neste link um problema semelhante ao meu:
    https://qt-project.org/forums/viewthread/28220

    A sugestão foi voltar a Qt 4.8, sera isto correto?



  • Resolvi o problema da seguinte forma, realmente Qt 5 e Cmake muda bastante em relação a Qt4 e Cmake, mas depois de se entender as mudanças, verifiquei que ficou até mais simples, segue uma configuração minima do Cmake para um projeto em Qt 5 com um arquivo main.cpp e um form projetado no Qt Designer, mais um arquivo de recursos(qt resource file):

    project(projeto)

    cmake_minimum_required(VERSION 2.8.9)

    set(CMAKE_AUTOMOC ON)

    set(CMAKE_INCLUDE_CURRENT_DIR ON)

    find_package(Qt5Widgets 5.2.1 REQUIRED)

    find_package(Qt5Sql 5.2.1 REQUIRED)

    find_package(Qt5Core 5.2.1 REQUIRED )

    find_package(Qt5Gui 5.2.1 REQUIRED )

    find_package(Qt5PrintSupport 5.2.1 REQUIRED)

    set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${Qt5Widgets_EXECUTABLE_COMPILE_FLAGS}")

    set(CMAKE_BUILD_TYPE "Debug")

    include_directories(${QT_INCLUDES} ${CMAKE_CURRENT_BINARY_DIR})

    set(projeto_SRCS main.cpp TelaPrincipal.cpp )

    qt5_wrap_ui(projeto_SRCS TelaPrincipalParent.ui )

    QT5_ADD_RESOURCES(projeto_SRCS icones.qrc )

    add_executable(projeto ${projeto_SRCS})

    qt5_use_modules(projeto Widgets Core Gui Sql PrintSupport)

    Abaixo, alguns links sobre Qt 5 e Cmake e migração de Qt 4 para Qt 5.
    http://www.kdab.com/using-cmake-with-qt-5/
    http://qt-project.org/wiki/Transition_from_Qt_4.x_to_Qt5
    http://qt-project.org/doc/qt-5.0/qtdoc/cmake-manual.html
    http://www.kdab.com/porting-from-qt-4-to-qt-5/
    https://www.kdab.com/modern-cmake-with-qt-and-boost/
    http://qt-project.org/forums/viewthread/28456
    http://qt-project.org/doc/qt-5/cmake-manual.html
    http://www.kdab.com/automated-porting-from-qt-4-to-qt-5/


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.