Compiler wird nicht gefunden



  • Hallo @all,

    ich habe mir bezüglich dieses Problems schon manche der Foreneinträge angesehen, jedoch haben sie mir leider nicht weitergeholfen.

    Ich habe "Qt 5.2.1." mit dem "Installer for Windows" auf mein Win7Desktop System installiert.
    MSVC 2010 32-bit war vorher schon installiert und bei der Qt-Installation habe ich auch für diese Version einen Haken gesetzt.

    Trotzdem, wenn ich ein Beispiel kompilieren will, bekomme ich die Meldung:

    "Fehler: Qt Creator benötigt einen Compiler zum Erstellen des Projekts. Bitte richten Sie einen Compiler in den Kit-Einstellungen ein."

    Dort ist nur der MinGW-Compiler bei der automatischen Bestimmung erkannt worden.

    Was genau muss ich tun, damit auch der MSVC 2010 32-bit Compiler erkannt wird?
    Analog dazu, was muss ich tun damit auch die MSVC 2010 64-bit und MSVC 2012 64-bit Compiler erkannt werden?

    Ich kann mir leider nicht helfen und bin Euch dankbar, auch wenn die Frage zu diesem Thema Euch vlt schon zum Hals raushängt aber ich bin trotz diverser Foren und Erklärungen nicht in der Lage, Qt einzurichten...

    Danke im Voraus.

    NACHTRAG:

    Habe im nachhinein Windows SDK7_1 heruntergeladen, dieses sagt mir, ich habe sogar die neueste Version vom VSC++ 2010 Compiler...
    Ich weiss nicht weiter



  • Hallo cURLE, ich konnte das System auf Win7 erst dann zum Laufen bringen, nachdem ich die 64-bit Version von Qt deinstalliert und die 32-bit (mingw32) installiert hatte. Normalerweise arbeite ich unter Linux und kenne die MSVC-Varianten nicht.
    Unter Qt - Einstellungen - Ersetllung und Ausführung kann man die Kits bestimmen - das wäre ggf. einen Versuch wert.



  • Hallo clochydd,

    das müsste ich erst noch ausprobieren.
    Ich hatte meines Wissens nicht die Möglichkeit zwischen Qt32-bit bzw Qt64-bit zu wählen da ich den WindowsInstaller heruntergeladen habe.

    Das merkwürdige, bei meiner Freundin habe ich es gestern auch installiert und alles lief problemlos, jedoch ist auf ihrem Rechner nie ein Compiler installiert gewesen; es wurden aber alle erkannt, die ich über den WinInstaller angehakt habe...

    Ich blicke da leider nicht durch, werde es mal versuchen wie du geraten hast. Danke für die Antwort...



  • Also Leute,

    folgendes hat meine Probleme gelöst.
    Ich habe Visual Studio C++ Express 2010 32-bit UND Visual Studio C++ Express 2012 32-bit und 64-bit deinstalliert und im folgenden neu installiert.

    Compiler wurden plötzlich erkannt.
    Aber neues Problem: Beim Compilieren kam der Fehler

    "LNK1123: Fehler bei der Konvertierung in COFF. Datei ungültig oder koffupt."

    Dieses Problem kann man lösen wie hier beschrieben:

    "Hier der Link":http://stackoverflow.com/questions/10888391/error-link-fatal-error-lnk1123-failure-during-conversion-to-coff-file-inval

    Ich hoffe, falls bei euch mal solche Probleme auftreten, dass Ihr Euch hier behelfen könnt.

    Danke und bis bald.


  • Moderators

    Creator erkennt eigentlich alle MSVC compiler automatisch. Wäre interessant zu wissen, was da nun schief gelaufen ist. Mehrere MSVCs gleichzeitig installiert zu haben schein keine gute Idee zu sein, da werden immer mal wieder komische Effekte in der Microsoft Knowledge Base dokumentiert.

    Für MSVC 2010 brauchts ein Paar Fixes, damit C++ ordentlich tut. Ich vermute, Du hast die nicht drin...



  • Ich musste die Qt-Installationen bzw. Verbindungen zu MS-Compilern folgendermaßen durchführen:

    1. QtCreator -> "Projekt öffnen" -> Projects -> Manage Kits -> Build & Run -> Qt Versions

    2. innerhalb dieses Tabs auf "Add..." klicken und den entsprechenden Pfad zu qmake angeben.

    3. Daraufhin MUSSTE ich QtCreator neustartet, erst dann waren die Compiler/Debugger erkannt und entsprechend auswählbar. Weiterhin wird bei mir immer noch eine rote Meldung gezeigt, funktionert trotzdem alles problemlos.

    4. im Tab "Kits" auf "Add" klicken und den passenden Compiler auswählen.

    5. nicht vergessen auch das Windows Driker Kit (WDK) zu installieren, erst dann kann man auch schön debuggen


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.