Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

PySide Phonon missing deprecated symbols



  • I'm building PySide 1.2.1 on Ubuntu 12.04 with the lib phonon-dev package installed following the "Building PySide on a UNIX System" instructions and everything builds nicely. I take the egg and easy_install on a yocto Linux system and when I do a:

    python
    from PySide.phonon import Phonon

    I get complaints about undefined symbols on functions that the headers installed with lib phonon-dev have PHONON_DEPRECATED(). Obviously a mismatch of something doing the build. What am I missing here?? Thanks!!


Log in to reply