Qt 5.2.2 + Raspberry Pi (Raspbian Wheezy). Cross-Compilation.



  • Good evening, everyone. I am sorry, this text was translated by google and promt, because I russian-speaking man. Please, help me fill some of the gaps in knowledge concerning a subject of this topic. Not so long ago I began to study raspberry and questions have been raised, the solution of which takes a lot of time due to poor knowledge of the area open source projects in particular Linux. A time every day less , because I am a student , and each day brings me closer to the session. To an essence. I found a lot of documentation, how build Qt from source codes for cross-compilation of programs on Raspberry Pi in particular given on this site. And practically everywhere write, that raspbian image necessary mounted to a /mnt/rasp-pi-rootfs. In general all anything, but after build Qt, installation and all other, application in the "Creator" successfully building, but the app does not start, and in an output is written "Not clearly what to launch". Just specify that setting Creator was performed competently fully in compliance with instruction. Is that here except this: "Then go to the "Rasperry Pi" kit tab-> System Environment and add LD_LIBRARY_PATH which is set to /usr/local/qt5pi/lib". How many have not tried, I did not understand what the "Rasperry Pi" kit tab and where it is. In general, in fact here is the first question. In the settings I configured the connection to the board, and as I understand it, in the process of launching Creator must pour the executable file (with all the necessary libraries?) and perform the launch. However, since the creator writes "Not clearly what to launch", he doesn't do it. Why? And if it's not so, what configure this connection? Generally, "one write two in mind", we go further. Copy the executable file on the single board computer and try to run, we get the message, that libraries missing in system. It should be expected, copy the libraries in the directory with the executable file and we get the same error, strange in Windows it usually worked… In general I was plagued by the following questions: what to do with libraries? May need to copy them to a specific folder on the raspberry and add the path to it in the variable path. Or to connect a flash card raspberry to the computer and on an assembly step somehow to specify a way for installation of libraries? How to make so that not simply worked, but also was the correct, adequate decision? And it is possible to set the launch from Creator?

    UPD: After build and install Qt for cross-compile, in /mnt/rasp-pi-rootfs/usr/local created folder qt5pi and Qt5.2.2. It is normal? Maybe qt5pi folder need to move on raspi? Also, on my computer in /usr/local created folder Qt5.2.2, but there are no libraries.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.