Important: Please read the Qt Code of Conduct -

Problem with eglfs

  • Hello,

    I have strange issue with eglfs plugin. I'm using fully upgraded Arch Linux ARM + Qt 5.2. QmlViewer works flawlessly using eglfs, but all other programs (qmlscene, examples, simple hello world program) are starting without visible windows. It seems that shader used in eglfs for rendering can't be created for some reason, for all programs except qmlviewer.

    I have tried different memory splits and video settings, but results are always same. This is how console output looks like when I run qmlscene:
    @EGLFS: Unable to query physical screen size, defaulting to 100 dpi.
    EGLFS: To override, set QT_QPA_EGLFS_PHYSICAL_WIDTH and QT_QPA_EGLFS_PHYSICAL_HEIGHT (in millimeters).
    EGLFS: Unable to query screen depth, defaulting to 32.
    EGLFS: To override, set QT_QPA_EGLFS_DEPTH.
    This plugin does not support propagateSizeHints()
    QOpenGLShaderProgram: could not create shader program
    QOpenGLShader: could not create shader
    QOpenGLShaderProgram::attributeLocation( vertexCoordEntry ): shader program is not linked
    QOpenGLShaderProgram::attributeLocation( textureCoordEntry ): shader program is not linked
    QOpenGLShaderProgram::uniformLocation( isRaster ): shader program is not linked@

    Does anyone know how to solve this problem?

  • hello srdjantot,did you solved this issue? i have the same error with Qt5.12.5 , i can run with eglfs, bug i cannot see my application, when i clicked screen ,the slot have responseļ¼Œ seems the application is

  • While creating EGLFS console-trdx-image did you follow the instructions as per this article.

  • @tenrisab4o It seems there's no URL to follow from your post...

Log in to reply