QtCreator 3.0 beta?



  • I'm trying to get Qt Creator running on Windows 7 64-bit for BB10 development. Following "these instructions":http://qt-project.org/wiki/Qt-Creator-with-BlackBerry-10 for Qt Creator 3.0 beta:

    • I installed Momentics 2.0 NDK,
    • added API level 10.2.0.1155,
    • set up my device & keys,
    • installed Qt 5.1.1 for Windows 32-bit (MinGW 4.8, OpenGL) containing Qt Creator 3.0 beta

    As a veteran BB dev I already had signing keys, which I imported into Momentics. I can successfully package, sign, deploy and debug Cascades apps on Z30, Z10 and DAC.

    I can also successfully compile and run the "Hello World" Windows Desktop applications from Qt Creator.

    However, in Qt Creator 3.0 >Tools > Options there is no "BlackBerry" tab as described in the documentation. Also, under Help > About Plugins, the Qnx 2.8.1 plugin is greyed out.

    I also tried running bbndk-env_10_2_0_1155.bat from an administrator command line then starting QT Creator from the same command line, as described "here":http://developer.blackberry.com/native/documentation/core/qt_porting_tools.html with the same result.

    What am I missing?

    Cheers, - Jon -



  • Notice that momentics is not needed for QtCreator to work. You need never start it to do BB work if you get Creator 3.0 working.

    I have not tried the distributed beta, but it should include the Blackberry stuff. Including a way to download the latest SDK.

    The documentation you pointed to is for the 2.x series of Creator, they should be updated (rewritten, really) after v3 is finalized.

    So please check your menus and settings for blackberry stuff, things have moved around a bit since the day that the wiki page documentation were written.



  • Thanks for replying Thomas!

    "These instructions":http://qt-project.org/wiki/Qt-Creator-with-BlackBerry-10 are pretty recent, updated last monday according to wiki. They cover Qt Creator 3.0 and API level 10.2.0.1155, so they should be fairly up-to-date.

    I know Momentics itself isn't used, but as far as I can tell the QNX plugin does use the toolchain and precompiled Qt libs from BB. Or not?

    My menus and settings don't include any BlackBerry stuff. That's the problem.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.