Qt Creator linux x64



  • Witam,
    zainstalowałem Qt Creator na ubuntu x64 lecz nie mogę nic kompilować, ponieważ wyskakuję błąd że nie mam ustawionego kompilatora. W jaki sposób mogę go ustawić?
    Z góry dziękuje za odpowiedz.


  • Moderators

    Najpierw musisz zainstalować kompilator:
    @
    sudo apt-get install build-essential
    @

    Potem odpal Qt Creator - powinien wykryć zmiany automatycznie. Jeśli się to nie stanie, musisz zaktualizować listę kompilatorów w opcjach a następnie ustawić ten kompilator w Kits.



  • Uzywam PCLinuxOS. Zainstalowalem Qt 5.1. Niestety nie da sie pracowac. Qt Creator nie wspoldziala z kompilatorem qmake, komunikat: "No compiler can produce code for this Qt version". Przecie qmake zainstalowal sie wraz z calym pakietem. Dlaczego nie wspoldziala? Sposob przedstawiony powyzej w mojej dystrybucji nie moze byc zrealizowany, poniewaz brak w repozytoriach build-essential. Co zrobic w takiej sytuacji?


  • Moderators

    Bibilioteki Qt na linuxie są zgodne z kompilatorami G++ i clang. Musisz zainstalować te kompilatory sam w jakiś sposób (zależy od dystrybucji, nie znam twojej, to nie wiem jak). Qt tego nie robi za ciebie, bo na Linuxie z reguły G++/ clang są bez problemu dostępne.

    Są też dodatkowe wymagania, jak sterowniki OpenGl, etc. Tutaj możesz zdobyć częściową listę: "link":http://qt-project.org/wiki/Building_Qt_5_from_Git.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.