Important: Please read the Qt Code of Conduct -

Help please!!! Compile and then run the application in qnx!!!

  • Hello!
    I beg for your help! Installed Windows 7 64! In VMWare installed QNX! Download and install Qt 5.0.2 for Windows 32-bit (MinGW 4.7, 650 MB)! Established connections to ssh with QNX!
    Run any instance of Qt Creator, but it compiles and runs on Windows! A must for QNX! Tell me, please, what you need to do the settings, what software is installed and the libraries for some ways to push for the creation of applications for the launch of the QNX! Need more inskruktsiya possible! Thank you! Perhaps cash reward!
    P.S. I'm from Russia, so the text is translated from Russian to English translators)))

  • Hello and welcome,

    I'm not going to be helpful on the topic, but I'd like to at least point you to the "Russian languge part of Qt forum": You can post there as well in your native language while still getting some attention.

  • QNX and blackberry focus on Qt4.8 right now.

  • I think that BB can run Qt5, but stock QNX can run only Qt4.8.x.
    I have Qt4.8.4 compiled and running on QNX 6.5, So if you still need help with it let me know and I can try to help you.

  • Hi portoist,

    I'm certainly not new to Qt on Windows and Unix/Linux, but I am new to Qt on QNX and new on this forum. I am also new to the company I work for now, where we try to switch from Photon to Qt.
    I was able to configure and build the Qt library on a Windows 7 PC, with this configuration:

    @configure -opensource -platform win32-g++ -xplatform qws/qnx-i386-g++ -no-exceptions -qt-zlib -qt-libpng -qt-libmng -qt-libtiff -qt-libjpeg -no-qt3support -arch i386 -no-inotify -no-iconv -opengl es1 -no-xmlpatterns -nomake examples -D QT_NO_GLIB@

    We work with QNX Momentics and I was able to build an application after having added the Qt include and lib directories to the project properties. I copied the Qt libraries to the QNX (virtual) machine, moved my executable to the QNX machine and tried to execute it. It aborts with the following errors:

    Failed to load platform plugin "qnx". Available platforms are:

    Abort (core dump)

    After having read some items on the internet I copied

    but that didn't help.
    I understand that you have got it working. Could you please help me out. I would be very grateful.


  • Hello,
    I am using virtual machine with linux and Momentics SDK to compile Qt for QNX (And also to create binary of my App), here is my configure line:
    configure -xplatform qws/qnx-i386-g++ -embedded i386 -no-gfx-linuxfb -no-mouse-linuxtp -no-kbd-tty -no-qt3support -qt-gfx-qnx -qt-mouse-qnx -qt-kbd-qnx -no-exceptions -opengl es2 -nomake exapmles -nomake tests -nomake demos -nomake webkit -qt-gfx-vnc -opensource
    Then to run app on QNX target I have to kill Photon and execute app with -qws. Also set these:
    export QWS_DISPLAY="VNC:qnx"
    export QWS_KEYBOARD=qnx
    export QWS_MOUSE_PROTO="qnx:/dev/devi/touch0 qnx:/dev/devi/mouse0"

  • Hi,

    Thanks for your fast reply. I tried killing Photon (>slay Photon), but that killed everything immediately and shutdown the machine. I set the QWS environment variables. I don't have devi/touch0 and devi/mouse0 devices, so I don't know whether that will have any effect. Alas, executing my app with the -qws option did not work for me.
    I will try your configuration parameters, though I know that a number of them will not be accepted by the Windows version of configuration. But I give it a try anyway.

  • Well this is what we are using:
    slay Photon
    sleep 2

    Start keyboard and mouse driver

    /usr/photon/bin/devi-hid -Pr kbd mouse

    Start touch driver

    /usr/photon/bin/devi-elo -Pr smartset -b9600 -R fd -d/dev/ser2 abs -f/etc/calib
    Instead of killing photon you can try ending session in Photon environment - you click on some exit button and then you can choose if you want to logout, or logout and exit Photon. I don't remember exactly, I am on holiday and don't have any QNX virtual with me to have a look:)
    After starting keyboard,mouse and touch drivers it will look like freezed - but it isn't - you have to control your machine via telnet or ssh.
    I would recommend you to try compiling Qt for QNX on linux, it's easier.

  • Hi,

    I was able to build the Qt library for QNX on Linux and run a demo Qt app on QNX without photon running. You were right to build the library on a Linux host, as you definitely need a number of configure parameters that the Windows version of configure doesn't support/understand.
    At the moment I'm struggling to get a Qt app running with photon running as well.

  • Hi Gentlemen,

    I am trying to use Qt 4.8.5 on QNX 6.5-SP1 x86 platform (no photon), but always got error message.
    #./configure -xplatform qnx-x86-qcc -opengl es2 -egl -no-cups -no-xcb -no-eglfs -no-javascript-jit -no-gtkstyle -no-iconv

    Which edition of Qt do you want to use ?

    Type 'c' if you want to use the Commercial Edition.
    Type 'o' if you want to use the Open Source Edition.


    The specified system/compiler is not supported:


    Please see the README file for a complete list.

    But under mkspecs, it looks "qnx-x86-qcc" should work.
    Could you guys give me a help?


  • Hi Albert,

    Just back from holidays, I saw your request for help. I think you should specify a different xplatform. I used '-xplatform qws/qnx-i386-g++'. I use the same Qt and QNX versions and it worked for me. This is the whole configure command I used:

    configure -xplatform qws/qnx-i386-g++ -embedded i386
    -no-gfx-linuxfb -no-mouse-linuxfb -nokbd-tty -no-qt3support -qt-gfx-qnx -qt-mouse-qnx -qt-kbd-qnx -no-exceptions -opensource -little-endian

    Mind you: You should build this on a Linux box, since a number of parameters are unknown to the Windows version of configure.


  • Hi Marcel,

    Thank you very much for your help.
    Jan also gave me his/her configuration as:

    configure -xplatform qws/qnx-i386-g++ -embedded i386 -no-gfx-linuxfb
    -no-mouse-linuxtp -no-kbd-tty -no-qt3support -qt-gfx-qnx -qt-mouse-qnx
    -qt-kbd-qnx -no-exceptions -opengl es2 -nomake exapmles -nomake tests
    -nomake demos -nomake webkit -qt-gfx-vnc -opensource

    They are all very helpful, thank you all.

    Best regards,

  • Hello all,

    Can anyone of you explain me how can i run my app developed in qt4.8 in QNX6.5. As i am trying to run my app. while photon is running, GUI is not coming.

    These commands i added in /root/.profile
    export QWS_DISPLAY=qnx
    export QWS_KEYBOARD=qnx
    export QWS_MOUSE_PROTO=qnx
    export XDG_CONFIG_HOME=/root
    export QMAKESPEC=/usr/qnx650/target/qnx6/usr/share/qt4/mkspecs/unsupported/qws/qnx-i386-g++

    These are the commands i am executing:

    /usr/photon/bin/devi-hid -Pr kbd mouse
    io-display -d vid=0x8086,did=0x27ae
    ./myapp -qws

    On the other side when i run same app in text mode i am able to get GUI but touch is not working. For touch driver i am executing this command:

    /usr/photon/bin/devi-eGalax -Pr egalax fd -d/dev/ser2 abs &

    Please help me, its very urgent

    Thanks in advance

  • @portoist Would be possible to get compiled Qt4.8.4 package for QNX 6.5.0 SP1 for x86 platform? I am trying to build it and getting many missing header files errors.

Log in to reply