Important: Please read the Qt Code of Conduct -

Qt5 / XRDP / Remote Desktop / DISPLAY not taken into account or other problem? / Ideas?

  • Hi
    I set up the Qt for Pi toolchain using bakeqtpi.
    I mostly got things working.

    I am using xrdp (X Remote Desktop Protocol) and I connect from Windows where I have a virtual Ubuntu machine on which I run Qt.

    to work with the Pi display and I was surprised to not see anything appear from the Hello world Qt example even though the debugger showed things were as expected.

    I had set the DISPLAY environment variable to ":10.0", which is the id for the RDP display. Nothing showed on the remote display. Launching directly from a Pi-prompt where "DISPLAY" is already ":10.0" did not change anything either.
    Only when connecting a monitor to the HDMI port brought me "Hello world" on the display.

    I guess this has something to do with OpenGL, but I'ld still expect Qt to take the display setting into account and complain if that display does not have the required support.

    Any suggestion on how to get Qt working on a remote desktop display?

  • Have you compiled Qt with X support? I think Qt5 does not use X11 on RPi.... So you can't see anything with RDP protocol which works on X11 protocols....

  • I used 'bakeqtpi' which is based on the "Qt RaspberryPi Beginners Guide":

    I suppose that I have to recompile and add '-xcb' on the configure line and also add some packages as mentionned here:

  • Yes, whats right, you should recompile Qt with X backend support.

  • I compiled with the option active, but it looks like I have to get the xcb packages on the Pi and copy them to the root copy of the image under Ubuntu.

    "Note: PKG_CONFIG_SYSROOT_DIR automatically set to /opt/rasp-pi-rootfs
    The test for linking against libxcb failed!
    You might need to install dependency packages for libxcb.
    See src/plugins/platforms/xcb/README.
    Configuring QT Failed"

Log in to reply