Problem with Qt5 on pi while applying the qtjsbackend patch



  • Hi,

    I followed steps to build qt5 for raspberry pi as per http://qt-project.org/wiki/RaspberryPi_Beginners_guide

    But while applying qtjsbackend patch (git cherry-pick FETCH_HEAD), i am getting bellow errors

    @...~/qt5/qtjsbackend$ git cherry-pick FETCH_HEAD
    error: 'cherry-pick' is not possible because you have unmerged files.
    hint: Fix them up in the work tree,
    hint: and then use 'git add/rm <file>' as
    hint: appropriate to mark resolution and make a commit,
    hint: or use 'git commit -a'.
    fatal: cherry-pick failed@

    Also when i run git status
    git status
    @# On branch stable

    Changes to be committed:

    new file: config.tests/vfp2/vfp2.cpp

    new file: config.tests/vfp2/vfp2.pro

    new file: config.tests/vfp3/vfp3.cpp

    new file: config.tests/vfp3/vfp3.pro

    modified: qtjsbackend.pro

    modified: src/3rdparty/v8/src/arm/code-stubs-arm.cc

    modified: src/v8/v8.pri

    modified: sync.profile

    Unmerged paths:

    (use "git add/rm <file>..." as appropriate to mark resolution)

    both modified: src/3rdparty/v8/src/arm/assembler-arm.cc

    both modified: src/3rdparty/v8/src/arm/macro-assembler-arm.cc

    both modified: src/3rdparty/v8/src/v8globals.h

    #@

    Did any one face this problem?

    Is this means, this patch is already included in the git?

    Any help on this is much appreciated.



  • it means:

    bq. you have unmerged files

    simply commit the changes. merge it or patch it manually from console...



  • Hey Vimal have you been able to solve this. I am getting the same error.



  • To all concerned, do not run the patch. All changes have been committed to the main branch already. Qt5 will now compile on the Raspberry Pi without the need for patching as shown here: "http://qt-project.org/wiki/Native_Build_of_Qt5_on_a_Raspberry_Pi":http://qt-project.org/wiki/Native_Build_of_Qt5_on_a_Raspberry_Pi


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.