Auxílio para compreender onde esta o erro ao compilar o QT 5 no MSVC2010.



  • Salve rapeize....

    Estou com o QT5 instado em uma máquina virtual com o windows 2003 server. Neste tenho o MSVC2010 instalado. Dentro da ide ao acessar o menu TOOLS - OPTIONS - BUILD & RUN, sou informado pela abas kIT, QT VERSIONS e COMPILERS os dados referentes ao compilador do c para versão do microsoft.
    Ao executar um teste básico como gerar uma main e atribuir um button para depois fechar. Ao executar recebo esta mensagem...

    19:08:24: Running steps for project t2...
    19:08:24: Starting: "C:\QtCommercial\QtCommercial5.0.0\5.0.0\msvc2010\bin\qmake.exe" "C:\Documents and Settings\Administrador\Meus documentos\t2\t2\t2.pro" -r -spec win32-msvc2010 "CONFIG+=debug" "CONFIG+=declarative_debug" "CONFIG+=qml_debug"
    19:08:25: The process "C:\QtCommercial\QtCommercial5.0.0\5.0.0\msvc2010\bin\qmake.exe" exited normally.
    19:08:25: Starting: "C:\QtCommercial\QtCommercial5.0.0\Tools\QtCreator\bin\jom.exe"
    C:\QtCommercial\QtCommercial5.0.0\Tools\QtCreator\bin\jom.exe -f Makefile.Debug
    C:\QtCommercial\QtCommercial5.0.0\5.0.0\msvc2010\bin\uic.exe ..\t2\mainwindow.ui -o ui_mainwindow.h
    cl -c -nologo -Zm200 -Zc:wchar_t -Zi -MDd -GR -W3 -w34100 -w34189 -EHsc -DUNICODE -DWIN32 -DQT_QML_DEBUG -DQT_DECLARATIVE_DEBUG -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_CORE_LIB -DQT_OPENGL_ES_2 -DQT_OPENGL_ES_2_ANGLE -I"..........\QtCommercial\QtCommercial5.0.0\5.0.0\msvc2010\include" -I"..........\QtCommercial\QtCommercial5.0.0\5.0.0\msvc2010\include\QtWidgets" -I"..........\QtCommercial\QtCommercial5.0.0\5.0.0\msvc2010\include\QtGui" -I"..........\QtCommercial\QtCommercial5.0.0\5.0.0\msvc2010\include\QtCore" -I"debug" -I"." -I"." -I"..........\QtCommercial\QtCommercial5.0.0\5.0.0\msvc2010\mkspecs\win32-msvc2010" -Fodebug\ @C:\DOCUME~1\ADMINI~1\CONFIG~1

    CÓDIGO COM ERRO ABAIXO.
    \Temp\main.obj.404.16.jom
    'cl' nÆo ‚ reconhecido como um comando interno
    ou externo, um programa oper vel ou um arquivo em lotes.
    jom: C:\Documents and Settings\Administrador\Meus documentos\t2\t2-build-Desktop_Qt_5_0_0_MSVC2010_32bit_SDK-Debug\Makefile.Debug [debug\main.obj] Error 1
    C:\QtCommercial\QtCommercial5.0.0\5.0.0\msvc2010\bin\moc.exe -DUNICODE -DWIN32 -DQT_QML_DEBUG -DQT_DECLARATIVE_DEBUG -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_CORE_LIB -DQT_OPENGL_ES_2 -DQT_OPENGL_ES_2_ANGLE -I"..........\QtCommercial\QtCommercial5.0.0\5.0.0\msvc2010\include" -I"..........\QtCommercial\QtCommercial5.0.0\5.0.0\msvc2010\include\QtWidgets" -I"..........\QtCommercial\QtCommercial5.0.0\5.0.0\msvc2010\include\QtGui" -I"..........\QtCommercial\QtCommercial5.0.0\5.0.0\msvc2010\include\QtCore" -I"debug" -I"." -I"." -I"..........\QtCommercial\QtCommercial5.0.0\5.0.0\msvc2010\mkspecs\win32-msvc2010" -D_MSC_VER=1600 -DWIN32 ..\t2\mainwindow.h -o debug\moc_mainwindow.cpp

    CÓDIGO COM ERRO ABAIXO.
    jom: C:\Documents and Settings\Administrador\Meus documentos\t2\t2-build-Desktop_Qt_5_0_0_MSVC2010_32bit_SDK-Debug\Makefile [debug] Error 2
    19:08:26: The process "C:\QtCommercial\QtCommercial5.0.0\Tools\QtCreator\bin\jom.exe" exited with code 2.
    Error while building/deploying project t2 (kit: Desktop Qt 5.0.0 MSVC2010 32bit (SDK))
    When executing step 'Make'

    Obrigado desde já.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.